Error in Amlogic USB Burning Tool

I am trying to burn some third party firmware on my box but encountering this error in the log of burning tool.

[11:14:15 562]BL2 report Error, code= 32 
[11:14:15 563][HUB3-5]cmd error, cmdType:43984
[11:14:15 563][HUB3-5]Aml_Libusb_bl2_boot2 end! 
[11:14:15 563][HUB3-5][Inf]--Release Semaphore
[11:14:25 736][HUB3-5][Inf]--Detect Device remove timeout
[11:14:25 736][HUB3-5][Inf]--Device is connected
[11:14:25 736][HUB3-5][Inf]--Close device handle 0x00000930
[11:14:25 787][HUB3-5][Inf]--Open device handle \\?\usb#vid_1b8e&pid_c003#5&1e7d8db7&0&5#{a5dcbf10-6530-11d2-901f-00c04fb951ed}  0x00000930
[11:14:30 838][HUB3-5][Inf]--0-0-1-8
[11:14:30 838][HUB3-5][Err]--CheckFileRunState failed
[11:14:30 843][HUB3-5][Err]--[0x10303004]Romcode/Switch status/Identify/Error result
[11:14:30 844][HUB3-5][Inf]--Close device handle 0x00000930

Anyone knows what is the error code “32” in BL2 and why this may happen? I tried several firmwares but no effect!

Thanks

Can you provide more information?

  • Board
  • Firmware
  • Tool version

Thanks.

I am seeing that with some boards specifically a S905X2 board(X10 plus from pendoo) which I am tweaking with now

Version of tool is 2.1.7.0

Firmware is almost all firmwares which I downloaded from several sources. All of them fail with this error!

Thank you nick

No idea about the S905X2 board, but it should be the same as VIMs if you use the right images.

By the way, you can also try the V2.1.7.3 tool.

Thank you. Any idea about how to find what does BL2 error code mean?
The log shows error code 32 for BL2 but I think the source code of both burning tool and BL2 is closed unfortunately!

If you can access the debug UART, the UART log will be more helpful.

I tried that and I think it is helpful for community too to see the cause of “Romcode/Switch status/Identify/Error”

Here is the full log but the important point which I found out is that the BL2 contains several configs for DDR (in my case 5) . So the corresponding config of actual hardware RAM chip should be present in BL2. Otherwise all configs will fail and burning will not proceed anymore!

After exploring I found my config is DDR3 792Mhz but the BL2 did not have that config.

Can you help me to get a BL2.bin with 792Mhz DDR3 config?

Again Thanks Khadas!