Error during building ROM

#1

Trying to build an Android N ROM for VIM1, made a clean repo fetch and getting such errors:

rivers/built-in.o: In function get_wol_state': /home/alex/kvim1/common/drivers/net/phy/realtek.c:77: undefined reference tomcu_get_wol_status’
/home/alex/kvim1/common/drivers/net/phy/realtek.c:77: undefined reference to mcu_get_wol_status' /home/alex/kvim1/common/drivers/net/phy/realtek.c:77: undefined reference tomcu_get_wol_status’
drivers/built-in.o: In function rtl8211f_config_init': /home/alex/kvim1/common/drivers/net/phy/realtek.c:299: undefined reference tomcu_get_wol_status’
drivers/built-in.o: In function get_wol_state': /home/alex/kvim1/common/drivers/net/phy/realtek.c:77: undefined reference tomcu_get_wol_status’
make[1]: *** [vmlinux] Error 1
make: *** [sub-make] Error 2
make: Leaving directory `/home/alex/kvim1/common’
ninja: build stopped: subcommand failed.
make: *** [ninja_wrapper] Error 1

What can cause this error and how I may fix it?

0 Likes

#2

Can you show the git log information for kernel(common)? Thanks!

# cd /home/alex/kvim1/common
# git log
0 Likes

#3

Will provide soon, making sync once more.

0 Likes

#4

The thing, I need only a built-in hardware support, for extra devices only a USB touchscreen will be used (based on eGalax controller) and usb hid device, emulating keyboard, gps reciever will be used via UART. So searching for documentation how to exclude all unnecessary devices support avoiding dependecies hell and making further compilation (and kerner working) faster.

0 Likes

#5

Pls find the link below
Logfile

0 Likes

#6

You can try to rebuild your rom following below steps

# make installclean -jN
# make otapackage -jN
0 Likes

#7

Dear Terry, I’ve tried with make clean (not installclean). The thing is that error occurs when I make some changes to a building config files, that are totally not related with PHY and wifi subsystem, and the most wondering - when I’m commenting my changes at config files, so they are identically to default config, and building after make clean, these errors are repeating. What can be the reason of such behavior?

0 Likes

#8

Thank you very much, that worked! If you will advice me how to setup the idc file for the touchscreen, it will be brilliant (now it seems to work upside down)

0 Likes

#9

The default idc file for touchscreen should be work. You can have a try for it.

0 Likes

#10

In my build there are 3 IDC files qwerty, qwerty2 and AVRCP, the thing I’m connecting a USB resistive touchscreen controller (Egalax) and had to build and inject an usbtouchscreen module as per your guides. Some time ago I’ve made it working properly with Android 4.0.4, but there was a trick with an module parameters, like below:
insmod usbtouchscreen.ko reverse_y=1
And as I know there was a modified source module.

0 Likes