Error 25 during image cloning process

Hello to all,

I have a configuration with khadas Ubuntu fenix 1.4

I have difficulties to clone my system from one VIM4 to another.

I use OOWOW to dump the image, but I have systematically an error 25 during the writing process.

It’s dangerous because the error message stays displayed for 1 minute maximum, then it disappears and everything seems to have gone well. Then during the installation of the system, there is enough to launch the system as if everything was fine, but some packages are missing, others are incomplete, in short the system is totally unstable.

Can you please tell me what is this writing error 25 and how I can avoid it.

As a support to store my image, I use a simple USB key formatted in FAT32.

Thank you in advance for your help and advice.

please tell me more detail !

  • dump creation process was done without any problems ?
  • tell me oowow version?
  • can i get any logs screenshorts ?
  • please check dump image consistence before write it, its a common zstd archive file for example on pc can try something like this zstd -dc IMAGE > /dev/null && echo OK

PS: dump creation can be done without error but maybe SD/USB device have some READ/WRITE problems, can try to use other source for dump image, or make it by network: OOWOW User Manual [Khadas Docs]

Thx for your quick feedback

indeed the dump creation isn’t done without any problem, but the first time I was not behind the screen during all the process. it show a error 25 in writing process during 30s. then the message disappear and I believed that everything was fine. And it was not fine indeed.

OOWOW version is

OOWOW beta 220929.258 | VIM 4 | …

final log message :

message not to miss :

OK I will follow your advice and invest in brand new qualitative USB stick :slight_smile: , mine is indeed a usb adaptor with a sd card in it, it maybe not the smartest choice…

I’ll keep you informed

PS: please check eMMC device for READ/WRITE errors too via same oowow tnx

Hi HypHop,
thx for your help

here are my last results :

I did the eMMC check, it took a while … (1h10 min) , result = > everything is fine

I also tried again with a brand new USB key, and it give me the same results, at 33% of dump process, there is again a “sync write read” error 25…

Solved !

Error 25 only means that the file is to big !, it is the case if you unfortunately use a FAT32 support. when the file is bigger than 4.3 Gb it is the limit.

I have understood this when installing a generic system on a sdcard, and booted from there, to then use the standard dd command in shell.
thank to that I have obtained an explicit error message about filesize.

conclusion => no FAT32 support to save the image :crazy_face: !!! I should have thought it before, but you know sometimes in action…

thank you for the help hyphop, it helps me to go forward.

tnx for testing ! default sd card dump storages always exFAT, and we dont have this problems
Error 25 only means that the file is to big - right fat32 have 4Gb file size limitation

oowow will be improved, to make additional notification for situation like this