Edge2 suddenly doesn't boot anymore

Which version of system do you use? Khadas official images, self built images, or others?

Ubuntu 22.04 Server with cinnamon desktop and panfrost x11 driver

Please describe your issue below:

I was watching youtube. The fan was too loud at low.
So I’ve increased the low-mid and high temps to 75c 80c and 85c.

I don’t think this has to do with the issue but I had done that about 15 minutes before wifi suddenly stopped working.
Temperature didn’t go above 70c. I was keeping an eye on that.

So I tried searching networks, none were found.
I rebooted because I thought that would fix it. But now the board doesn’t boot anymore.

It stays on the Khadas logo. Nothing happens.
I am able to go into OOWOW. I reinstalled Ubuntu 22.04 Gnome. Everything seemed to go fine, but after install I reboot and again the same behavior.

I had been using this image the last 2 days without a problem. I was finishing my research to make a review video about it. So wanted to use it a while as main desktop. But suddenly this happens.

Anyone seen this behavior before? Is there a fix?

I find it strange and have no clue what happened.

These are the commands I used to higher the fan trigger.

echo 85 | sudo tee /sys/class/fan/trigger_temp_high
echo 80 | sudo tee /sys/class/fan/trigger_temp_mid
echo 75 | sudo tee /sys/class/fan/trigger_temp_low

I was also just typing on the forum when internet fell out to ask if there is a way to lower the speed for the low setting, so it would be less loud.
On my VIM4 I use a 5V fan on 3V pins and the other fan never goes on. Here no 3V pins.

I’ll try debugging tomorrow. Maybe try the Android install… I hope someone knows about this and its an easy fix. I had rebooted a few times today without problem. Never had a wifi problem.

Wifi also works in OOWOW.

I was just having so much fun with it.
Cheers, NicoD

1 Like

With a fresh installed Ubuntu also can’t bootup?

What I noticed with the fan that on the GUI side of things it always reverted to “auto”, is there an issue with the fan software?
What I would suggest is trying the Android image and taking it from there, I think that’s definitely worth doing and the fan software seemed bang-on there.

Good news everyone.
Without changing anything it boots normally again. I don’t understand how this can be.
I tried so much last night and couldn’t get it to boot anymore.
Now in the first try it just boots as nothing has happened.

The problem being me is, I now want to reproduce this issue to get to know why and how this happened.
I’ll let you know if/when I know more.

I had such a great setup with tons of games working. I’ll have to start again. Too bad. Now backup from time to time…

I’m happy it’s not broken. I was fearing the eMMC had died. Would have been a problem with this device not having sd. But I guess it should also boot from USB, haven’t tried it yet.

@numbqq Is there info on lowering fan speed for the low setting? Where is it declared? I guess it’s pwm, so should be controllable.
My theory is to lower the fan speed so much it doesn’t make much noise, and it also doesn’t overheat.
I don’t mind a 100% of the time on fan if it’s not loud.
Otherwise I can make an adapter for USB with resistor to have 3V with a 5V fan.

Please check here: