Edge2 stuck on boot

Which version of system do you use? Khadas official images, self built images, or others?


Please describe your issue below:

After flashing this image, the Edge2 doesn’t boot. It shows the Khadas logo, flashes to black briefly and then show the Khadas logo again, where it stays forever. No spinning wheel with the Ubuntu logo next to it as usual from the VIM3 images I’ve been flashing.

I tried several times on two different Edge2 devices, all with the same result.

When flashing edge2-ubuntu-22.04-server-linux-5.4-fenix-1.2-221018.img.xz, I get the same result.

I’ve even tried -gnome- images with the same result.

Update: I figured the device isn’t really stuck at boot - it’s just the Khadas logo never disappears, so I can’t login to the console. The same is true after installing X. Other than the display, the device appears to behave normal: I can ssh into it, install packages, start services etc.

BTW: Your leaflet is wrong: It says you have to press FUN + PWR to boot into OOWOW, but it’s actually FUN + RST, just like with the VIM devices. Also, I had to repeat this before it would actually boot into OOWOW. I’m running the beta version 221019.

Try plugging the power into the other type C port.

1 Like

Thanks. Unfortunately, it’s the same result.

I have the same issue with the VIM4 - see my post in the other board. This is a showstopper for us: We run a media player on the devices, so we need the HDMI to work.

Most important is to insure you have MINIMUM 24W power adaptor, I banged my head against the wall trying to figure it out and simply finding the right power adaptor (30W/2A) and high quality USB-C solved all the problems. Seems to be quite common issue on this forum.

Actually, I have both the original 24W and the 30W power supply from Khadas. That should be overkill to boot a device with just a mouse/keyboard and HDMI display connected. Anyway, power is not the issue because it shows me the Khadas logo all the time.

The behavior is the same on the new VIM4. Looks very much like a Kernel bug.

Also I can boot the Android image from OOWOW, except Android is useless for our use case.

Have you tried booting with no USB devices connected?
I’ve got this problem when I’ve got all my USB devices connected.
Boots fine without anything connected and then I can connect everything. I do have way too many USB devices for this board.

Where you get this information? It is press FUNC + RESET to activate OOWOW frmo user manual.

So the device is already booted but the hdmi screen show the khadas logo ? What’s the resolution of your screen?

Could you please provide the output of this command? cat /sys/class/drm/card0-HDMI-A-1/modes

And also provide the full kernel log. dmesg > kernel.txt, provide the file kernel.txt to me.