Edge2 Downloads via WiFi corrupted

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu, OOWOW

Which version of system do you use? Khadas official images, self built images, or others?

Khadas 22.04 1.4 gnome desktop, OWOO 221019.000

Please describe your issue below:

Downloads over WiFi both in OOWOW and Ubuntu are often corrupted. I couldn’t download the Ubuntu desktop distro successfully (xz invalid error each time) and downloads from the Snap store often result in MAC errors. It’s stable (but slower) if I use an USB 3 Ethernet adapter. My access point is a Ubiquiti UniFi U6-LR running on 5GHz. I’ve not had any similar issues with other clients connected to the same access point.

Post a console log of your issue below:

┌───────────────────write: FAILED!──────────────────────┐
│ IMAGE: edge2-ubuntu-22.04-gnome-linux-5.10-fenix-1.   │
│ DURATION: 43 sec                                      │
│ ----------------------                                │
│ ERROR: [e] XZ broken                                  │
│ ----------------------                                │
├───────────────────────────────────────────────────────┤
│                       < BACK >                        │
└───────────────────────────────────────────────────────┘

Hello @Uxian

@hyphop will help you about this issue.

looks like local network troubles

do u have other khadas device ? for testing with same network equipment ?

other suggestions, create hotspot on phone just for testing, and check how-its works

Thanks for the suggestions. I have a 5G router that I can try but I’m now thinking it might be a memory or storage issue instead. I tried doing an install from a USB stick. The first time I tried to apply the image it failed with the same XZ error and the second time it succeeded. I’m running an eMMC read/write test now but couldn’t see a RAM test anywhere in the OOWOW menu.