Edge v won't boot from sdcard, mask mode not working

Which system do you use? Armbian, if it works.

Oowow isn’t available for edge V. I’ve been searching for a reasonable Linux release.

I have armbian on sdcard. I went to install a really old manjaro, but that wouldn’t boot. Although it did in the past.

Which version of system do you use? Khadas official images, self built images, or others?

I am unaware of khadas linux images.
I will see if I can find one to try.

Armbian bullseye was working, but I’d rather have a rolling release, like manjaro or Arch.

Please describe your issue below:

It does not boot to sdcard, or go to mask mode. Following those directions, it blinks blue/white with red, then stays red.

Currently I can only boot to android in emmc. Android can see the sdcard and it looks like a live Linux boot disk.

I have not found any documentation that explains the lights or the buttons besides the maskrom sequence.

It does continue to boot to Android in emmc. But booting to sdcard seems very random, until it stopped completely. and I can’t get it to work no matter the image or the sdcard.

It doesn’t help that the instructions for booting from sdcard are non-existant.
So I’m not sure how to reliably do it.

I have tried fresh armbian sdcards, my old armbian sdcard and manjaro sdcard.

I created them like always on Linux with dd. I will see if I can find another. This card is not well supported.

Post a console log of your issue below:

As far as I know there is no log or a way to get one. 

Any help is appreciated
Thank you,

create a oowow bootable microsd, boot from it, in menu
advanced >emmc >format (or clean ) emmc.
power off , insert your bootable microsd, power on, now it should boot from sdcard!

I just tried to boot to oowow SD. That does not boot either.

I have also tried the official images for android pie, freebsd and manjaro.

Maybe I am doing something wrong.

On plug in I press function 3 times.

For oowow I held function and pressed reset according to the instructions. The red light remains on and it does nothing.

I have a few sdcard to try now, but none work.

Looking at the oowow sdcard in Android it all looks good.

It’s like the edge doesn’t know how to boot anymore.

I do have the battery attachment, but I have realized that doesn’t work with booting from sdcard, or apparently with linux. so I have it disconnected. After disconnecting it booting was more reliable, until it stopped altogether except for emmc which still boots.

And In case there are questions I have tried most of these many times.


I think my SPI flash must be corrupted.
I tried this solution with no luck. I shorted on boot after boot, a variety of ways with no luck.

The SPI flash is in a slightly different spot on the edge v. But it is well marked.

Anyone here?

At this point I think my edge v is an android brick without functioning boot from sdcard.

If anyone has any clues how to reconfigure it to have mod mask and boot from sdcard, it would be greatly appreciated.

I am very tempted to throw the board away as it has been nothing but frustration since I bought it and now it only runs Android with no possibility of anything else.

What’s the android version you used now ?

It is the one installed inn emmc when I received the board originally. Its not plugged in anymore or I could look. It’s from before oowow existed.

The version of Android is Android 9 pie.

Hello @Ericag

@ivan.li will check and update here.

Hello~ @Ericag

You can try to use TST mode to boot from the SD card, please follow the instruction below:

Quickly press the Function key 3 times in 2 seconds, then release the key. The system will reboot and boot from the SD card.

Yes I have done that many times. It did work at one time but no longer works.
I have tried many different cards.
Oowow, the official download for a few different images, armbian which did work…

No matter what I try it does not boot from sdcard. It blinks red and white or blue with 3 double blinks and turns red again.

No amount of waiting results in anything. No drive activity light. Nothing.

I did the test and it’s normal.Here’s how to do it.

1.Use this software to burn the firmware below to the sd card


2.After burning successfully, disconnect Edge power supply. Insert an sd card. Reconnect the power supply and quickly press the Function key 3 times in 2 seconds, then release the key.The system will reboot and boot from the SD card.

Yea, well you didn’t do it on this board.
Those steps result in nothing.
I did them again just to humor you.

Pushing the button 3 times does nothing no matter which card I put in.

Could you possibly read my original posts where I explain that I have done these steps many times?

Hello @Ericag

We will help you to resolve this issue but we need more information from your side.

Do you have a chance to setup a serial debug console? You can follow the documentation below:


And then follow the steps below to try to boot oowow and provide the full serial debug log to me.

OK. I ordered one of those. It will be here Friday.

1 Like

This thing finally arrived. I will try to do it tomorrow.