EDGE-V Usb device not recognized

I burned the image to the SD card with Rufus. There is last screen page on my screenshot. The window with wizard did not appear

how to start krescue for Edge - we have two ways

  1. just insert SD card and reboot
    if Krescue system cant start
  2. try triple press KEY_F - its must work in any case

GOOD LUCK :wink:

1 Like

@hyphop. There are no problems with starting KRESCUE. I have a problem with boot KRESCUE ending

@hyphop. There are no problems with starting KRESCUE. I have a problem with boot KRESCUE ending problem

i have see message : RAMDISK is corrupt and OOOOPS on your SS
look like krescue image was not properly written or SD card broken


  1. try another SD
  2. rewrite image
  3. re-download image https://dl.khadas.com/Firmware/Krescue/system/Edge.krescue.sd.img.gz and check crc-sum https://dl.khadas.com/Firmware/Krescue/system/README.txt

Good day!
Tried using 4 different SD cards (2 x 8 Gb, 32 Gb, 64 Gb). The result is the same - CRC error.
Checksums compared - match.

Tried using Rufus, balenaEtcher. The result is the same.

@Lench are you trying to connect to Krescue over USB with windows PC ?
and execute Krescue commands ? (SSH over USB)

I didn’t have luck to burn image (neither Ubuntu nor Android) to Edge-V via PC - tried both Windows and Ubuntu hosts - no luck, see details here.

Only succeeded burning images to EMMC via Krescue.

Electr1’s post reminded me. When booting Krescue, don’t use your PC to power the Edge-V.

I am using 2.4 A power source :wink:

Sorry for the confusion, I was referring to user Lench.

Is there a manual on how to organize this?

I try without using a PC

Maybe the problem is in the U-boot? I bought EDGE-V for a long time

I was able to update the system to Android 10 using an SD card and SDDiskTool_en_v1.53. It’s a pity that I don’t need Android

Congratulate me, I did it. What I’ve done:

  1. Put Android QT https://dl.khadas.com/Firmware/Edge/Android/Edge_Qt_V200709.7z
    During installation, the SDDiskTool_en_v1.53 program rejected one of the SD cards, so it was removed from use.
  2. I wrote the KRESCUE image with the Win32DiskImager program
  3. Started KRESCUE, the monitor turned off, changed the monitor
  4. Next, as described by the respected RDFTKV, I launched the Wizard and selected the UBUNTU image, etc. according to instructions
    Thanks everyone!

Excellent news. Good job. Congratulations.
Thank you for the kind words.

@Lench this won’t work in windows,
good to see you fixed it :slight_smile:

So to conclude, the only way to burn image to Edge-V is through Krescue?

for ubuntu yes. there are at least two ways for android: SD card and krescue.

I get Formatting user disk failed error when trying to use SDDiskTool_en_v1.53 according to manual :thinking:

From tool log:
11:17:38 536 Rockchip Create Upgrade Disk Tool v1.53 start run
11:18:00 894 Start to write MBR…
11:18:01 112 Start to write Loader…
11:18:01 175 Start to write firmware…
11:18:01 190 Writing parameter…
11:18:02 190 Writing trust…
11:18:03 065 Writing uboot…
11:18:03 675 Writing misc…
11:18:03 847 Writing boot…
11:18:08 612 Writing dtbo…
11:18:08 802 Writing vbmeta…
11:18:08 815 Writing recovery…
11:18:16 441 Start to format user disk…
11:18:16 582 Error:FormatDrive failed,err=-13

When I got this error, I took another SD card. The error was on a card of type A2, I don’t know whether it is important or not

Thanks, I tried with different SD card (Samsung Evo Plus) and it worked - was able to burn Android image to SD card.

However, Edge-V doesn’t seem to initiate upgrade process - device is stuck on Khadas logo :thinking:

i somebody have usb flashing problem - we have always another solution

just start krescue from sd and install any images from net for one minutes :wink: and no need spend time

PS: Edge have new images for krescue - Krescue for EDGE (Rockchip rk3399)

NOTE: krescue started from SD by KEY_F x 3 times in any case