EDGE-V Descriptor Request Fails on Windows

I am attempting to flash the Ubuntu eMMC image to my EDGE-V board (it still has the factory Android image) but cannot get it connected to my PC. The PC is running Windows 10. I have tried both DriverAssistant 4.6 and 4.8. I am certain I am using the correct USB C port and I have tried both the Key sequence and the the TST sequence. I can get the board to appear in Android recovery mode as well as flashing the Blue LED but in all cases Windows 10 reports that the USB device failed because the descriptor request failed. Specifically:

Windows has stopped this device because it has reported problems. (Code 43) A request for the USB device descriptor failed.

Any help would be appreciated.

@jwoolston Maybe you can uninstall the driver and install again . And I think you need to check you whether the data line has the function of data transmission .

@Frank, thanks for the response. I have tried uninstalling/reinstalling several times, even with reboots. If you are referring to the USB cable, it is one which I routinely use to communicate with Android devices via ADB so I know the data lines are connected.

https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc725873(v=ws.10)

@goenjoy Following the steps at the link you provided result in identical behavior.

The problem must be on your Windows 10 system. Would you like to upgrade your operating system?

I have all available updates. The hardware is less than 6 months old. Literally every other USB driver for assorted android devices works. Ubuntu 19 also reports the device descriptor fetch fails as does Android (attempted to verify usb descriptor only).

TST Mode (Recommended)

  1. Power-on Edge.
  2. Quickly press the Function key 3 times in 2 seconds, then release the key.
  3. You will see the Power-LED (Blue) blink for about 3 seconds. After the Power-LED (Blue) turns OFF, this indicates that the board is in Upgrade Mode (Maskrom Mode).

image

Perform the above operation to see if it can appear as shown in the figure

I see the blue led flash for a few seconds (inconsistent rate, I assume that’s fine).

Confirmed RKDevTool version of 2.65

Same result as before, device descriptor fails. Note that according to windows this could be a driver failure or a device failure. Also note that the board boots its factory Android image from the eMMC drive just fine if I don’t enter TST/Maskrom/recovery modes.

I tried the above procedure with power from the dedicated USB-C PD port and USB-C data from the data port as well as power and data both from the USD-C data port with identical results.

As annoying as it would be, is it possible for me to install the Ubuntu image to eMMC from an SD card (so that I do not have to run the image from the SD card)?

Can you try another computer?

I had the same problem. Could not get a Windows 10 based system to see the Edge-V. I tried multiple notebooks with same results. I found that a Windows 7 system worked, no problems. I did not troubleshoot any further or try to resolve the Windows 10 issue.

I have an old windows 7 system I can try. Someone should really look at updating drivers if thats the case as all my systems have moved past Ubuntu 16/18 and Windows 7 is nearly impossible to come by these days.

Have you tried the latest drivers and tools for Windows?
https://github.com/rockchip-linux/tools/raw/master/windows/DriverAssitant_v4.91.zip
https://github.com/rockchip-linux/tools/raw/master/windows/FactoryTool_v1.68.02.rar or
https://github.com/rockchip-linux/tools/raw/master/windows/AndroidTool_Release_v2.71.zip

1 Like

No difference I’m afraid. I have yet to try the suggested Windows 7 platform.

@goenjoy I tried a different (older) machine with Ubuntu 18 and had the same problem. The dmesg log on device plug is attached:

[ 1446.876190] usb 2-2: new full-speed USB device number 2 using xhci_hcd
[ 1447.004283] usb 2-2: device descriptor read/64, error -71
[ 1447.240348] usb 2-2: device descriptor read/64, error -71
[ 1447.476201] usb 2-2: new full-speed USB device number 3 using xhci_hcd
[ 1447.604258] usb 2-2: device descriptor read/64, error -71
[ 1447.840258] usb 2-2: device descriptor read/64, error -71
[ 1447.948262] usb usb2-port2: attempt power cycle
[ 1448.600178] usb 2-2: new full-speed USB device number 4 using xhci_hcd
[ 1448.600420] usb 2-2: Device not responding to setup address.
[ 1448.808385] usb 2-2: Device not responding to setup address.
[ 1449.016173] usb 2-2: device not accepting address 4, error -71
[ 1449.144176] usb 2-2: new full-speed USB device number 5 using xhci_hcd
[ 1449.144387] usb 2-2: Device not responding to setup address.
[ 1449.352392] usb 2-2: Device not responding to setup address.
[ 1449.560167] usb 2-2: device not accepting address 5, error -71
[ 1449.560282] usb usb2-port2: unable to enumerate USB device


Try the method here

I had tried those this morning (9 hours ago). There was no difference.

I am deeply concerned about why linux is unable to even get a valid descriptor from the device. Getting a USB descriptor is part of the host-device enumeration process and completely separate from any driver or knowledge of how to talk to a device. The fact that the linux USB stack is reporting that the device descriptor reads are failing suggests something wrong with the device.