Edge-V board not working

Please describe your issue below:

I bought Edge-V Pro to test the board (in the official store on Aliexpress), for a quick start for an AR glasses project.
I wanted to buy a batch in case of a successful decision.
I turn on the board with the display (from khadas). A window with the logo “khadas” is displayed and then the red diode burns endlessly and nothing happens.
The power adapter is branded “khadas”, the cable is also normal.

Tried two solutions:
First try:

  • downloaded the image “edge-ubuntu-18.04-lxde-linux-4.4-fenix-1.0.11-220430.img.xz” from here firmware/Edge/Ubuntu/SD_USB/
  • downloaded the SDDiskTool program (when trying to write the downloaded image to a 32G SD card, it says “failed” when you click “Create”)
  • downloaded the balenaEtcher program and used it to write the image “edge-ubuntu-18.04-lxde-linux-4.4-fenix-1.0.11-220430.img.xz” to the SD card
  • inserted SD card into Edge-V
  • rebooted
    Outcome: no splash screen “khadas”, endless time black screen. DOES NOT WORK.

Second try:

  • downloaded USB driver_v5.1.1. Launched, clicked “Uninstall”, then “Install”
  • downloaded the AndroidTool_Release_en_v2.71.zip program from the link
    products/edge/tool/
    because on the page
    android/edge/UpgradeViaUSBCable.html
    AndroidTool_Release link leads to RKDevTool_Release in Chinese
    products/edge/tool/RKDevTool_Release_v2.82.zip
  • put the board “in update mode” (did according to the instructions)
    android/edge/BootIntoUpgradeMode.html
  • connected Edge-V to computer via USB
  • launched the AndroidTool_Release program
    Bottom line: the computer does not see the board. AndroidTool_Release - writes “Not founds device”. Device Manager in Windows - Edge-V does not see.
    I am using Windows 10.

As a result, I can’t do anything with this board.
Is this a defective board or is there another reason?

Boot with Krescue on an SD card.

I did it as in this instruction (by the way, the link [MaskROM mode] does not work, like many other links in the khadas documentation).

  1. downloaded from dl.khadas.com - Index of /firmware/Krescue/dump/
    image Edge.krescue.sd.img.gz and recorded the unpacked image
    board.Edge.time.1641796810.size.16494582 .SIZE.67108864.ver.220110_266.krescue.sd.img
    to SD using Etcher



  2. inserted the SD card into Edge-V and turned it on.

  3. Hangs on the splash screen and nothing happens.

I am attaching photos and videos.

This is by far the bad board I have ever worked with. I have worked with a wide variety of other frendlyArm, raspberry, Banana, TorpedoWireless SOM, virt2real and other boards.
For the first time I see problems with the board at the start of working with it. And a terrible technical support and sales team that can ignore messages for weeks and not respond to them.
I believe that with such an attitude, this board cannot be used in serious projects.
At this moment, I lost almost 3 months to communicate with the sales department (when I discussed the complete set, since I originally planned for a batch of 100-1000 units). Could not resolve issues with the purchase of batteries. Now the problem is with the board out of the box.
I am very disappointed and will try to discourage others from buying this board on electronics forums.

@Ilya_Zelenskiy I’m really sorry for the trouble. Can you catch the boot log? In this way, our technical team can understand what is happening to this board.

How can I get the download log? I need instructions on how to get it.

Krescue works with HDMI displays only ! but same time u can use UART serial and WEB/SSH remote access to control device

First of all, there must be a serial port debugging tool, otherwise you can’t catch it.


Unable to enter upgrade mode problem. Maybe the inductor of the red arrow in the picture was damaged by collision. Can you visually judge whether the inductor is broken or warped?
@Ilya_Zelenskiy Or you can take a clear picture of the red arrow on the board and upload it to me.

1 Like

Are you talking about “USB Serial port debugging”? I have a programmer.
How can I get a log from the board through it?



Edge-V Baudrate: 1500000

1 Like

This is absolutely no different. With HDMI and with a khadas display, the result is the same.

Here is a video without an SD card.

Here is a video with an SD card (which I recorded yesterday).
board.Edge.time.1641796810.size.16494582 .SIZE.67108864.ver.220110_266.krescue.sd.img

Here’s a video with the SD card (I just overwrote the image - first run).
board.Edge.time.1641796810.size.16494582 .SIZE.67108864.ver.220110_266.krescue.sd.img

Here is another video after rebooting the board with the SD card.

I made several videos and photos of this component.

photo:





Additional photos




I’ve connected USB-TTL to Edge-V (but haven’t turned it on yet). Correctly? (your photo is different). Do you need to connect the power pin?
Red-Vcc
Black-GND
White-RXD
Green-TXD


Next, you need to connect the board via USB to the power supply and USB-TTL to the computer?
I can’t find instructions on how to properly work with USB-TTL with your board.
https://docs.khadas.com/android/edge/SetupSerialTool.html
Should I connect USB power to the computer and USB-TTL to the computer?
Or should I connect USB power to the power adapter and only USB-TTL to the computer?

Tried your link

Can’t install driver
https://dl.khadas.com/Tools/CH34x_Install_Windows_v3_4.zip
Writes failed.
I have a more recent CH34 (as a 3D printer, laser and CNC machine are installed, but now they are disconnected from the USB port)
I have SecureCRT
Set up as it says.
Does the board need to be connected to a computer or a power adapter?

Updated the CH340 driver (just in case).
But it doesn’t help.
When the board is connected, it is reflected in the device manager (but with an error).



image
Do not take photos on a flat surface so that the welding points cannot be seen. As shown in the figure above, take a clear picture in the direction of the red arrow, that is, a total of 3 pictures.

image
A yellow warning indicates that the serial port driver has not been successfully installed.
If the installation is successful, see the following figure.

Can you take a picture and upload it? Want to confirm your USB to serial port device.

image
Neither of these places is set correctly. The correct one is shown in the figure.


Ok. Photo:



I have the latest CH341SER.EXE from the official site.

It includes CH340. Your CH340 installation file won’t install on my Win 10.
But the problem remained. I tried two programmers. But the result is 0.

What I used to do in the photo is following your instructions on the documentation site. You obviously need to complete and correct the instructions. Now it has a lot of errors, it is outdated, the steps are very poorly described.

As I said, I tried two programmers.
Attempt 1.




Only Cp210 works fine for it (because it is based on it). In this case, I can make a connection. But nothing happens.

Attempt 2.




I used the programmer from yesterday in the photo.
I manually installed the CH340 driver on the USB.
But I can’t connect to the board. Writes an error.

I’ll probably have to ditch this board. And I will try to use Radxa Zero in the project, because it works stably out of the box.
I’m wasting a lot of time, this should work by default. I can’t imagine how it was possible to send the board without checking it. How much marriage will there be in this case if I would buy 100-1000 units at once. This is terrible.


There seems to be a problem with the welding. There are two ways to handle it:

  1. If you have welding ability, you can try to re weld. This is the fastest way.
  2. You can contact the sales department to return or exchange goods.

image
The serial port cannot be connected. This is not related to the board. It is the serial port itself. Because even if the serial port is not connected to the board, no matter what baud rate is set, it should be connected successfully.