Edge Ubuntu 20.04 V0.9.1-20200602 Initial Release

did you try erasing the eMMC ?

Yes, you can. MASKROM mode works in any situatuion to falsh the image to eMMC.

I am not sure what you want to do?

So now I won’t be scared to flash images anymore.

For 2)
Basically I just want to avoid unnecessary steps to connect device to a PC and then also enter MaskROM Mode to change the OS on the EMMC.
Wanted to know if there is a way to do everything from Ubuntu/Linux running from a micro-sd card to access the whole emmc storage, erase it and flash Linux/Android to it.
But I think KRescue in development will solve this problem.

Something else
If I want to keep Android on emmc and only test Ubuntu/Linux OS’s like Manjaro from a micro-sd card
then the Linux OS’s can’t boot from the micro-sd card since the Android u-boot on the emmc(which is a lot older) loads first and not the one on the micro-sd card, so you just get a ‘no signal’ on your tv.

Is there some way Khadas, you or @goenjoy can
upgrade the u-boot used by Android so it can boot both Android(4.4, 4.19 kernels) from emmc and Linux(5.7 kernel) from micro-sd cards?
At the moment only a Linux OS using a 4.4 kernel can boot from a micro-sd card if Android is on emmc. If you want to eg. use Manjaro(5.7 kernel) on a micro-sd card, you need to keep the emmc erased. But a strange thing is, LibreELEC that also uses a 5.7 kernel can boot correctly from a micro-sd card if Android is on emmc but not Manjaro here - Manjaro ARM Linux - Preview1 - Edge-V Pro
Maybe it’s a Manjaro problem?

I haven’t tried this Edge Ubuntu 20.04 v0.9.1 image yet, but will later today.
Not sure if it will have the same problem but maybe since it uses 2020.04 u-boot which Android on emmc doesn’t.

just to put it here for troubleshooting, i face this error
with image

EDIT: solved the issue by updating Balena Etcher to latest version which is by the time of writing is v1.5.98

Hello, I have khadas vim 3, when I recorded the image on emmc and first loaded, everything was fine and I was very excited about this new firmware. But when I turned off khadas and the next time I turned it on, the screen remained black all the time, and the white led on the Board was blinking. Then I installed Android on emmc and ubuntu on cd card, and ubuntu started loading on the screen, then I waited 5 minutes and the screen went black again. Now I don’t know what to do. But still I like this new firmware, I hope that in the future you will be able to fix it, thank you for your work, it is very cool.

1 Like

@AKBAAR Balena etcher faces a lot of problems with that ability to write compressed image, better uncompress it and then flash the image, that feature was a Beta release and has been now removed,

Though it was a nice feature allowing you to save space, it was very faulty

yes krescue for edge will be ready soon Krescue for EDGE (Rockchip rk3399) - at this moment we are in testing stage

1 Like

yes solved the issue with updating Balena Etcher to latest version v1.5.98 .

1 Like

good now that it works, but i recommend win32 disk imager, it is smaller, you can take disk backup and save the image from the sd card or usb

1 Like

so now , I tried to install TensorFlow && keras
i reached the walkthrough here

i get this error , am guessing its not implemented yet in the new OS

It is not a supported package, try a different platform.

Its better to build tensorflow… Why use tensorflow it only uses CPU not even GPU… things will be too slow…

Yes, Training model on SBCs Sucks, but I don’t want to carry a GTX970 all day with me either

I hear you @AKBAAR, I totally agree, not everyone has powerful computers that can train these models on the fly,

1 Like

that’s why cloud computing exists :stuck_out_tongue:

But you can’t have a nice broadband connection anywhere you are either, everything has its limitations,
Only God’s computer could achieve such crazy tasks :grin:

lol u can access cloud VM with 64Kbps connection

Atleast hope that kind of connection is Stable, or it is practically useless, A lot more Ground work needs to be laid for Cloud Computing so it is Available for the everyone :slight_smile:

It is accessible u just need a SSH connection… Many of them are using it now

Hmm, guess I could try something that,