EDGE Android Pie V191227 Rom Release

@goenjoy, MikesCo was asking if the app was compatible or not, and it that it needs to work…

This is a Google App. It can be used, but whether it can meet his requirements or not can only be verified and tested by himself. After all, there are so many functions.

Thanks for answering his question, he also had this other one…

@goenjoy Thx for the quick answer. Many SBC don’t have a GMS certificate and therefore don’t work with the Google core apps. I’ll get the system tomorrow and will try it out.

@goenjoy We where able to install “Android Device Policy” but unfortunately we got the error message

“Can’t set up device / This device doesn’t allow encyption, which is needed for setup. For help, contact the admin.”

After setting a PIN, we than entered Settings / Security & location / Advanced / Encyption & Credentials / Encrypt Tablet

This brings up the message that the device is not connected via a Power Charger (even so it is). We overcome this issue with shell command dumpsys battery set usb 1 with the App
Remote ADB Shell. This will mock this device as if it were connected to a USB charger. But unfortunately after trying to encypt the device it will restart but does not encrypt.

You can verify it on Android 10.0.
I verified it on Android 10.0 firmware, but after this interface appeared, I couldn’t continue :sweat:

The error message comes after the QR code scanning. Is the encryption working on Android 10?

Android10.0 SDK already supports file base encryption function.

@MikesCo you are using Edge-v or Edge SoM ?

None of our SDKs contain GMS.

Will try it out in the next hour! Thx!

I thought that Android Device Policy needed GMS. I might have misread something. If it works it works :slight_smile:

Edge-V currently but the Edge SoM is ordered to test :wink:

maybe try using the other USB port for powering…
Or, can try to test using khadas juice-board and battery with the Edge -V…

It might see the battery and dismiss the error…

It needs to detect a power charger not a battery. Tried both USB-C Ports but not working. Maybe with the Edge SoM as this has a DC connection. @goenjoy any chance to tweak this in the SDK so Android is detecting the power charger if plugged into the USB-C?

If you connect a battery and then connect to USB, you will be recognized as having a charger plugged in. If there is no battery, it will only be considered as power supply. After all, there is no battery, and there must be no charging function.

1 Like

Makes sense in some way. Therefore it detects the “charging” and not the “charger”. After all, it would be nice if the USB-C will just be detected as a charger without the battery. But no problem, I will order the battery.

@MikesCo, please note if using the Edge SoM, you will need the Captain board to attach the battery and the juice board to attach the Battery with Edge-V

1 Like

This is a special requirement, you can study the code here and modify it.


With the EDGE Android 10.0 V200709 Rom Release release it worked. No extra steps for encrypting, etc. needed. Thx a lot!!