Edge 2 not booting into Ubuntu

I just got my Edge 2 (Maker edition) today and was able to connect it to Wi-Fi in OOWOW. From there, I did a OOWOW update which seemed to go OK. Now I’m trying to get an OS installed (Ubuntu 22.04 - the ones in the OOWOW “wizard”) but, after installation and reboot, I’m greeted with the Khadas boot logo and that’s it - it never goes away. I tried attaching a keyboard and mashing some keys to “wake it up” but nothing. I tried both the Server and Gnome/GUI installs of Ubuntu but no change.

Power is via USB-C from my desktop USB (with rapid charging). I don’t have the “official” power adapter. The only things plugged in are the HDMI cable and power cable USB-C.

Any help would be greatly appreciated.

I think you need to prepare a 24W USB-C adapter.A lack of power supply can cause this kind of problem.

I went and bought a USB-C power adapter that’s within the power range - 9V/3A (and many others). Since I highly doubt it’s power related after trying several options, I installed Android (from OOWOW) and it booted just fine all the way to the desktop. So - either the Ubuntu images aren’t solid or there’s something else. Maybe because of my screen being an ultrawide? Any way to see some debug/UART output?

Thanks for your help

@numbqq, @Frank Any ideas what else I can try?

What’s the resolution of your screen? Could try to install the Ubuntu image again and capture a full boot video of the screen?

I’m connecting via HDMI to an LG UltraWide 29" 21:9 2560x1080 (model=29WL50S). I’ll capture a video soon, but it will likely just show a black screen followed by a black screen with the Khadas logo.

Here’s the video of install and reboot. Not much to show or debug with, tbh. Dropbox - 2022-12-16 12.58.49.mp4 - Simplify your life

This is definitely a bug. Someone else is reporting the same thing and I used their workaround (booting without HDMI, waiting a few seconds, plugging in HDMI).

Related ticket: Edge2 ubuntu 22.04 powered on with HDMI failed

Does this workaround works for you?

  1. please show some logs from serial console UART ?
  2. whats happens with leds indication ?
  3. try any other image just for check !?

I had the exactly same problem. I never thought about my display. I had the board connected to a 1440p monitor via HDMI. After reconnecting it to regular 1080p monitor, the desktop ubuntu booted. Hope this might help you :slight_smile:

Yes, it does. Thanks

I’ll get UART logs just as soon as Khadas releases the UART POGO adapter :wink:

LEDs are totally normal according to the docs. They report that the system finishes initial booting and is in normal operation.

I tried 3 images (as previously stated). The only one unaffected is Android. Both Ubuntu images are affected and the workaround can be used for them.

For Android usage on Edge2 need setup boot-mode to emmc value, user can easily setup device boot mode via OOWOW, by default boot-mode always emmc, and no need to change…