DVB/DTV Extension Board for VIM2 (VTV)

CoreELEC released 8.90.1 with image specially for KVIM2: https://github.com/CoreELEC/CoreELEC/releases
You need only burn image to new SD card via Rufus or Etcher, put it in box and reboot.


I tried on 166e. Intelsat19 buffer many times and few channels no picture no sound.
Thank you.

dear @Rmiino

PowerVU func is not supportted yet in the existing software.
for Condition Access Module, Please go into Installation–> DVB S/S2, and then press “999999” to show hiden menu, you will see cccam, newcam, biss functions there.


I burn CoreELEC released 8.90.1 image to new Sd card via Etcher and reboot my box but my KVIM2 boot directly to android !!
what’s the problem ?
Do I need activate multi-boot ?

Yes. You need to activate multi-boot.

1 Like

If you boot with the reset button pressed whilst booting into your libreelec SD this should boot to libreelec. Thereafter whenever the SD card is present it will boot to Libreelec otherwise it will boot to Android.

1 Like

I can booting to CoreELEC form SD Card
great image
remote control ok
iptv (used IPTV Simple Client ) ok
live TV ( with vtv board DVB-S used TVheadend ) ok
Play some video files ( mp4 , mkv,…) ok
but I have a problem
if i want to watch iptv channels by IPTV Simple Client Must be disabled or deleted TVheadend Client , same problem if i want to watch live TV with vtv board by TVheadend Must be disabled IPTV Simple Client
How can I solve this problem or is there a way to watch iptv and live tv dvb-2 without collision

Doesn’t TVheadend support IPTV inputs ?
It seems your two pluggings are interfering with each other - use one or the other.


You can configure tvheadend servicing iptv. Use e.g. this tutorial:https://www.matthuisman.nz/2017/06/libreelec-tvheadend-iptv-freeview-nz.html


Hi Guys,
I have a problem to install multiboot. In Recovery i can choose my zip file, but theres always the failure Permission denied failure 22???

In Coreelec occasionally the vTV board simply goes to sleep and the box needs to do a reboot to wake it. Not a big deal but the wife sometime gets confused.


Any simple way to install on eMMC?

The new build of Coreelec has InstalltoInternal reinstated.
Its a simply matter of opening a SSH session and issuing the command installtointernal.
It may hang on the first reboot and if it does then repeat the above steps.

Do so at your own risk because if anything goes wrong no one will help you to fix it and you will probably have to reinstall Android from scratch. Having said that, it worked without issue for me.


1 Like

Not working on VIM2 max from USB flash drive. Don’t try it at home :slight_smile: After executing the script, everything looks like going good, but the result is VIM2 Max stays on Khadas logo after reboot. I tried two times with different options but the result is the same. I’ll try DD way later, but my conclusion is that the only firmware’s different from Khadas original is from balbes150.

Doing fork of the fork …

Will update you as soon as i get more information by going deeper with coreelec.


OKAY, you need to perform the installtointernal twice! After that you will have Coreelec installed on eMMC. My proposition is to do the installtointernal by system reboot because off all this mount/unmount and read/wright privileges. This will avoid double install procedure.

It is still cycling in any reboot “SAFE MODE” …
I gave up for today and will investigate where is the problem next weekend if there is no new “official” release up to then :slight_smile:

twice? do you mean not to remove the SD card on first reboot to execute the installtointernal script again? two steps with reboot in between?

Do not remove SD card on first reboot. After the first reboot you will stick on Khadas logo. Power on/off to boot again and execute script again. After that you can remove SD card and boot from internal. This was wot worked for me.

if i try to start my vim2 with this image it boot and boot again and i can go ahead with my installatioin…anyone knows what is happening? i hadn’t overwrite the .dtb file.

Can anyone please help me?

Using this image: CoreELEC released 8.90.1 with image specially for KVIM2: https://github.com/CoreELEC/CoreELEC/releases

I can’t go ahead from the coreelec logo, should i do anything more once i have burn the image? Such us replace the .dtb file?

Please help!! I’m stucked trying to restart it

It should be OK since it is working fine on my VIM2 and its setup to detect and autoinstall the dtb file.
However I would take the KVIM2.dtb out of the dtb folder and place it in the Libreelec partition. Then rename it dtb.img and try again.

If that fails I would try reinstalling the latest version of Android and trying again. Multiboot handling changed between the earliest Android and later versions.


1 Like