DVB/DTV Extension Board for VIM2 not detected


#1

Hello everyone. Unfortunately the Extension DTV Board, even after trying both the latest and second latest vtv firmwares in the khadas docs site, taking apart and reassembling the whole tv box and cleaning all contacts, is not not recognized by the Khadas VIM2 Max board. All the lights are on both on the vim2 and the extension board, and I am using the recommended power supplies. I tried connecting only the vim2, then only the dtv board, then both. In all cases all lights turn on on both the boards and everything works fine, but when I open the vtv app I get a message saying that the vim2 does not recognize a dtv board and gives me a link to the article page to buy it (very useful…). Please, let me know what I can do to fix the problem. I already submitted a ticket and I will paste the answer below. The thing is, they say the installation isn’t correct, but everything turns on and works even if I only plug in the dtv board so it can’t be an installation problem. My guess is the dtv board is faulty but I was told to try making a topic on this forum, so that’s why I’m making it. Thank you, Marco

Gearbest Customer Support At 01/02/2018 03:17:10
Dear Marco,
We sent your video to our technical team and they replied us :
It seems that installation or vTV board is something wrong. But we still need more details for confirmation. Can you provide us more details like: some necessary photos about the installation or the back side hi-res photos? Would be better for you to create a topic at Khadas Forum( http://forum.khadas.com/ ), Khadas or vTV team will reply and follow up the issue there.
We sorry for any inconvenience caused to you.


DTV board not working
#2

It could be a software problem but I don’t know what it could be. Ask for any details you need to help me and I will provide them right away. Thank you very much in advance.


#3

Hi, marcoc:
Sorry for the late response, and the troubles you met.

@Frank.DTV It seems that is the problem of the vTV board?


#4

Dear macroc
Sorry for the problem, could you please help us to take a photo of the VIM2 & VTV board connnection, I would like to check if the pogo pin connecttion are ok or not, and also please help us to check if there any pogo pins are broken or damaged.


#5

Dear Frank,
please believe that the pogo pins are all perfect and well connected between the 2 boards.
I have tried before to unmount the 2 boards and checked all the contacts, and they are all in perfect conditions.
Now, the difficult thing is to understand if the vtv is faulty, or if there is a problen in the VIM2 (hardware or software) that does not allow the recognition of the VTV.
The best thing to do, I believe, is to proceed with the substitution of both.
Let me know. If you believe that there is something else we can do to check which of the 2 boards is not properly functioning.
Thanks


#6

Which version ROM did you installed?

And does VIM2 works fine separately?

And are you a developer or a normal user? A printing log(if you know how to) will be help us to locate your issue.

Thanks!


#7

As I said in the first post, I tried both the latest and second latest vtv firmwares on the khadas docs site.
Yes, the vim2 works without the vtv board on it.
I am not a developer but I’m good with tech, so if you tell me how to get the log I will post it here.


#8

dear marcoc,

  please refer to 

Setup Serial Debugging Tool

to setup RS232 debug console

Start VIM2&VTV,  after system running into android status and also goto active 

VTV app (even you can not start it successfully), run command ’ logcat *:E ’ in the
RS232 debug console, please help to caputure whole logcat information, and send it to me

thanks.


#9

Hello, I’ve taken a look at the documentation you sent me and it appears I have to buy a converter to do this. Are you expecting me to spend more money to buy the usb to ttl converter because of a problem caused by the board? Or is there a way to get the log without it, maybe by connecting via the usb-c and installing a console?
Kind regards,
Marco


#10

Hi marcoc

  • for windows, please try this:

#11

Dear kenny,
thank you for the very clear instructions. I did as you explained and I got the log file. It is very long, so I uploaded it to MEGA at this link https://mega.nz/#!tIAwnRLL!T5dK6Y-hSDSR2VtkSJPTB_HBUFuuy7--XaBN-D_m1FU . I hope this can help you figure out the problem.
Kind regards,
Marco


#12

Hello, I don’t own the VTV, but if I am not mistaken it requires its own power supply. If true, has the power supply been checked? Or an appropriate substitute power supply tested?
I am unfamiliar with the VTV, so forgive me if this is erroneous. :slight_smile:


#13

Hi, Marcoc:
Thanks for the log.

Can you kindly capture another log with run adb dmesg > dvb_kernel.log and post to us?

Thanks!


#14

dear marcoc

It’s really sorry for cause you the trouble.

We have checked your dvb.log file and found that was problem of the VTV board,
Please ask Gearbest after service and they should send you a new one.


#15

Hello, thank you everyone for the replies. I will answer the questions in order to not cause any confusion.

@RDFTKV if you read the first post, you will see that I tried all possible ways of connecting the power supplies. I tried only connecting the vim2, only the dtv board and also both at the same time. In all cases all lights turned on and the vim2 worked fine, but it wouldn’t see the dtv board.

@Gouwa Here is the link to the new log. https://mega.nz/#!EEh23Jxb!Lhtmrw3S6x0ZYa15YJ5wZbcyHO8EJVakfYzVGuATvY4 I checked it myself for a bit and found a part where it says some dtv gpio pins are invalid and that the board was skipping them. I don’t really know what that means, I’m just hoping to point you in the right direction. Thank you for the help and the time you spent looking at the other log. I’m now asking gearbest for a new board, but I got the log in case you want to find out what the problem was caused by. If you need anything else, just reply to this post, I will still be checking it regularly.

@Frank.DTV Thank you for the help. I will proceed to ask for a new board and provide a link to this thread, since the support wanted to know if the problem could be solved before proceding to change the board.

Everyone, thank you again for the help. It would have been nice to solve the problem, since the shipment will probably take more than a month, but still thank you very much for helping me and spending your time to do so. As I said, I will be checking the thread regularly in case you need anything else (logs, photos, etc)
Kind regards, marco


#16

Hi, Frank.
I have VIM2 MAX and VTV, my friend has it too.
The kits were purchased in September 2017. But the second tuner lay new all this time and was not connected. Today I got it and connected, but it doesn’t work. The first tuner does works, the second does not.
What am I to do?


#17

Gouwa, may be, Can you help me?


#18

Hi, Davemf:
@Frank.DTV can help you. But I called him and he is out of his company now. I think you need to wait for him.


#19

dear davemf

What do you mean of first tuner? is it for DVB T/T2/C or S/S2?
Can you connect to the VIM2 via ADB, if so can you please help me to take a logcat (logcat *:E) from system startup till enter into VTV application.


#20

I mean, I have 2 pcs of VTV board.
One of them (VTV board) does not work.