DSD distortion noise on Toneboard1 with latest firmware (2.0)

I installed Volumio and a Toneboard (with latest firmware v 2.0) on a RPI4 8GB. Everthing is oke, but when trying to play DSD files, i only hear loud distortion on both channels. I thougt the tone should play dsd file fine?

With the option: DSD over PCM: i hear no sound at all…

The files rates:
Samplerate: 2822400 Hz / PCM Samplerate: 88200 Hz
Channels: 2
Bits per sample: 24
Bitrate: 5645 kbps
Codec: DSD64

Please help me out here.

i think its volumio problem
please check alsa driver state

How can i check alsa driver state and what must i say?

play DSD file and get next information about alsa driver play state
grep "" /proc/asound/card?/pcm?p/sub?/hw_params

Where can i see the information? On the webpage of Volumio?
When i play the dsd file, i don’t see that kind of information.
I’m running Volumio and Tone board via a Raspberry 4

not sure, u must find some way to get linux shell, for example via UART, ssh , etc …

BTW: what about toneboard led indication - DSD stream have special color and its not same as for PCM!

The color of the led is always WHITE? No difference if i play music or not, or playing music of different type of files.

BWT, when ik select the option in Volumio: DSD over PCM: i hear no sound at all (no distorion also)

volumio@volumio:~$ volumio@volumio:~$ grep “” /proc/asound/card?/pcm?p/sub?/hw_params
/proc/asound/card5/pcm0p/sub0/hw_params:format: DSD_U32_BE
/proc/asound/card5/pcm0p/sub0/hw_params:subformat: STD
/proc/asound/card5/pcm0p/sub0/hw_params:channels: 2
/proc/asound/card5/pcm0p/sub0/hw_params:rate: 88200 (88200/1)
/proc/asound/card5/pcm0p/sub0/hw_params:period_size: 11025
/proc/asound/card5/pcm0p/sub0/hw_params:buffer_size: 44100

sorry its was only for Toneboard2 and not for Toneboard1

yes driver work in DSD mode, but u listen only noise , right ?

  • how its was before ? for example for prev firmware
  • please check how its works on PC
  • maybe share link to DSD file from your tests for me, i will try to check it too

I don’t know how it was before, as i have the Tone just for 1 week, straight out off the box put the latest firmware on it.

But i found when playing DSD files, you have to put the volume in Volumio on level 100. Then there is no distortion noise and i just hear the music playing!!!

yes right only 100% volume level need