Does overclocking work?

Does overclocking via /boot/env.txt and max_freq_a53= and max_freq_a73= work for anyone? I tried to change the frequencies as documented here, but it seems to be ignored. cpufreq-info returns just the default frequencies.

I have the latest VIM3_Ubuntu-server-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530.

you need to update your firmware, 200530 is quite old atm,
just follow these commands to update…

sudo apt update
sudo apt full-upgrade
sudo do-fenix-full-upgrade
sudo reboot

Instructions from here:

1 Like

Well, I did do-fenix-full-upgrade (I think it contains the two previous steps already), but since I’m on mainline kernel 5.7-rc7 it didn’t upgrade much and the overclocking is still not working.

The update you posted is for kernel 4.9.

Ah yes, sry I forgot to mention, that it was only published for 4.9 kernel, no clue on Mainline at the moment…

the link does not specify which version of the assembly, only for vim3L there is a clarification

Its for VIM3/3L, what do you mean by version ? please clarify,

I mean by this link

It also says: For release V0.9.3-20200814 or later, which I didn’t understand first as the latest downloadable images have the date 20200530.

Is there an easy way to change between mainline and 4.9 instead of rewriting the SD card with a new image?

Hmm, maybe it was not updated perhaps, will need to ask Numbqq about it…
but please wait, khadas team is on vacation…

you need to check with the Fenix github repo, they have fresh builds now…
you need a Github account to access the files…

This below link is the latest one…

I am not sure that is possible…

I’m now using the latest 4.9 and still no luck with overclocking. The lower than default frequencies work, for example setting max_freq_a53=1704 and max_freq_a73=2100 works, cpufreq-info shows the correct frequencies 1704 and 2100.

But anything above the default frequencies does not work. E.g. max_freq_a53=1908 and max_freq_a73=2304, cpufreq-info shows just the default frequencies 1800 and 2208.

Do the higher than default frequencies work for someone?

Is this with v200530 ?
directly from image folder ?

if so, please update it…

sudo apt update
sudo apt full-upgrade
sudo do-fenix-full-upgrade
sudo reboot

I already updated. Otherwise there is no max_freq template in /boot/env.txt. But I’m still not getting frequencies higher than the default.

Lowering frequencies works.

Facinating, it seemed to worked for me,
but I was last using an fresh build of Fenix, perhaps you could try that ?

I think maybe you need to tune up the core voltage.

I have tried for a whole day, and I want to control the temperature of the vim3 board but I failed

I upgrade the os to 20200814, and set the max_freq to 1200, which means the cpu frequency is under 1.2Ghz, but the temperature will go to over 60 degree all the same.


What exactly do you have in mind? I see that Fenix produces also kernel 4.9.232 as the one I’m running now. Maybe it is the dtb file?

I’m a bit confused as I see and old file /boot/dtb.img (88587 May 30) and a newer file under /boot/dtb/kvim3_linux.dtb (88879 Sep 28). Which one is actually used?

Fenix produces also a file kvim3_linux.dtb with length 88879.

There is apparently a variable BUILD_TYPE=release or BUILD_TYPE=develop. I suppose the default is release. Are you using develop?

I am not much familiar with the newer Fenix build parameters yet…

the dtb.img in the /boot directory is the active one…

I don’t know what is the error created… I am distant from my device at the moment, I will try it on my device when I get to it.

I think the updater somehow missed /boot/dtb.img and left an old file there. When I copy the new file /boot/dtb/kvim3_linux.dtb to /boot/dtb.img overclocking works! :slight_smile:

I just checked the mainline image and it seems the dtb.img is the correct one meson-g12b-a311d-khadas-vim3.dtb (50964 Jun 2). Slightly older than the one on 4.9, which explains, why overclocking does not yet work there.

That’s great!, hope you are enjoying your Speedy SBC now :slight_smile: