Does anyone have a fully working AOSP 11 Device Tree for the Vim3 Pro?

Done much searching and many test to find a fully working AOSP 11 Device tree for the VIM3 Pro.
AOSP only has VIML not the Vim3, I even found and tested this:

Which Did not work, first try Never loaded, nothing but errors durning boot, watched durning UART cable…
2nd try using reversion back, booted but no screen… Tried tweaking my own from master branch,
but not having much luck there.

Reason for wanting to compile 11, because 12 which has no problem building and working.
no GAPPS, I want a ATV working edition, and there is no gapps for ATV 12 as of yet.
Tried to build opengapps 11 internally but No go there either… wouldnt boot.

So I need android 11 to build gapps internally for a working ATV…

any help would be appriciated at this point. I am out of ideas…

thank you…

@Eliminater74 You can use latest Android 11 branch to test it.

$ mkdir aosp_a11 && cd $_
$ repo init -u -b android-11.0.0_r48
$ repo sync -j8

$ source ./build/
$ lunch yukawa-userdebug
1 Like

Thank you but I have already tried that as well… Images would be created but none would boot.

I build these sources in 9 hours and the image loaded successfully on VIM3, but the video slows down and the fan and LED control does not work. Therefore, immediately returned back to the old firmware

1 Like