Display Driver need for OBS steem services

Hello, I’m wondering if there is support for the Ubuntu display driver because I’m trying to install an OS. Model Vim4 version 22.04

Hello @rasbery_pi4

What you mean about the display driver ? Could you provide more details?

The problem is that when we install Ubuntu, after the necessary update, none of the programs respond. I mean not only downloaded programs, but even built-in settings.

Okay,it seems that latest Ubuntu update break the GPU, we have fixed it. Can you upgrade your system again?

sudo apt update
sudo apt full-upgrade
sudo reboot

thanks. It was fixed but not completely, Failed to initialize video. Your GPU may not be supported, or your graphics drivers may need to be updated. Can you give me some information how can i update your gpu vim4

If anyone has your vim4 device working and ready for updates. Can you upload it to a drive somewhere so that I can manually install this image, I don’t need anything except a working version where the obs system will work without problems

Hello @rasbery_pi4

We will check this issue on our side. You mean GPU works but OBS still not?

@ivan.li please follow up.

The following command may help you.

$ sudo apt update
$ sudo apt install obs-studio
$ sudo obs
1 Like

Yes, it works, but only when called from the terminal. In addition, can you explain to me how I can display the image with the guvcview program?
I do as it is given in the document, but the display does not appear.

VIM4 MIPI Camera


Are you using MIPI camera or USB camera?

Yes I use it but it doesn’t output any image.

using MIPI camera ,but it doesn’t output any image.

1.What firmware are you using?
2.Try this firmware: https://dl.khadas.com/products/vim4/firmware/ubuntu/emmc/vim4-ubuntu-22.04-gnome-linux-5.15-fenix-1.6-231229-emmc.img.xz

Yes, I use that version, but it seems that it has updates and bugs, because after booting and updating, how it should work, Ubuntu doesn’t work like that.

You can based on this image and then update your system. What issues you have ? What errors you got to use the MIPI camera ? Please provide the logs here.