Discussion - CoreElec Vs LibreElec vs ATV

I am prepareing my Vim3-pro to be used as an entertainment core system.

I would like a little input on differences and performance.

I am familiar with Kodi as I use it on my Nvidia Shield TV quite a bit.
I just tested the Superceleron ATV build and played a file on it but ran into the issue that the netflix app was the phone version and quite clumbsey to use. I expect this will be the result in most of the android builds.

Thus I am looking at Core/LibreElec builds now, but not fully ready to toss Android if advise can guide me to a working system

I want to be able to use:
Amazon Prime
Play from my NAS across wifi my collection of video files.
Use a bluetooth speaker system (sound bar) for all audio.
Boot and run from the built in Emmc memory of the VIM3-pro - I do NOT want to use an SD-Card at all.


Hey! the Nvidia shield has a certified Netflix, and the 2019 pro version also supports Dolby Vision, of course with a maximum resolution of up to 4K.

coreelec and libreelec are not for such streaming, or rather plugins can be found there, but they will be limited in the resolution of the video itself.

any core or libre system will work for this.

Currently only COreElec and ATV can do stuff that you need while CoreElec with input adaptive plugin can give you DRM content in 1080P while ATV might only be able to do it in 720p

Load CoreElec from sd card and flash it to emmc and done.

LibreElec will work but you might have to flash the Mainline version to emmc manually plus there might be some bug with seek (forward/backward), While there is box image which you can run over sd card for a quick test.

In my opinion CoreElec will fulfill all the requirements you have mentioned above.

Good Luck.


you probably mean the ATV-module from romodels / mododels, then yes. But if we talk about a normal ATV, then there are all DRM keys, and you can watch up to full 4K. All TVs on ATV or Nvidia shield TV have this support, there are still some TV boxes.

I should have added I am not worried about 4k or any of that, 720p is likley fine, 1080p I kinda expect tho.
its going to be used as an out door theater on a projector to a pull down screen on my deck.

1 Like

“Load CoreElec from sd card and flash it to emmc and done.”

tqvm, this looks like what I was hopeing for. So I will need to find an SD just to flash over to the emmc tho, that I did not expect but I get it, thanx.

1 Like

so far no go, I cannot figure out how to get coreelec installed :frowning:

Useing CoreELEC-Amlogic-ng.arm-19.1-Matrix_rc4-Generic.img

Tried 3 SD cards and a USB stick.
Flashed image onto them with Rufus 3.14
I have copied the file g12b_a311d_khadas_vim3.dtb to the root folder of the SD card and renamed it dtb.img

I have used the vim3 upgrade mode:

  1. Power on VIM3.
  2. Long press the POWER key without releasing it.
  3. Short press the ‘Reset’ key and release it.
  4. Count for 2 to 3 seconds, then release the POWER key to enter into Upgrade Mode. You will see the sys-led turn ON when you’ve entered Upgrade Mode.

It does not boot. into coreelec as expected.
All I get is the Khadas logo in the middle of the screen and it stays that way, left it for 30 min one time.

The Vim3 has a bootable Khadas created image of Android 9 on it loaded into emmc. This does boot no problem.

I dont know what to do.

did you follow this instructions on Coreelec Website? First ensure u have android on emmc so the uboot is legacy. Best way to ensure this is to use USB Burn Tool and flash khadas official android image to your vim3. You can get that image here:

Latest Burn Tool can be found here:

Then download the coreelec image and flash it to sd card… All the steps are on coreelec website:

**New installation**
Prepare an SD card *(class 10)* / USB flash drive as follows;

***NOTE**: On some devices, only 1 USB port is able to boot the device, you may have to try them all to see which one works for you, some boxes are also unable to boot from a USB drive.*

1. Download the latest ***.img.gz*** file from [here ](https://github.com/CoreELEC/CoreELEC/releases/latest).
2. Use [Rufus ](https://rufus.ie/), [usbimager ](https://gitlab.com/bztsrc/usbimager/) (or your preferred image writing software) to burn the downloaded image file to your SD card / USB flash drive.
3. If successful, the SD card / USB flash drive capacity will be shown as 512MB, this is OK as there is a second (hidden) partition for CoreELEC user data.
4. Browse to the ***Device Trees*** folder, now present on the SD card or USB flash drive, and copy the correct [***.dtb*** ](https://discourse.coreelec.org/t/which-dtb-do-i-use/389) image file for your device to the root folder of the SD card / USB flash drive, and rename it to ***dtb.img***.

*To boot the system **for the first time** you have to use one from the following methods, sometimes only one of these methods will work!*

* ***Khadas VIM***: insert the CoreELEC prepared SD card and boot into Upgrade Mode, CoreELEC will start automatically: [ Howto Boot Into Upgrade Mode - Khadas ](http://forum.khadas.com/t/boot-images-from-external-medias-like-sd-card-and-u-disk/1948)

Another option is to use KRESCUE to flash officially avaialble Coreelec nighly to vim3. It can be found at below link, but u just boot vim with a krescue sdcard and rest can be done inside its wizard.
https://dl.khadas.com/Firmware/VIM3/Coreelec/VIM3x.COREELEC.9.2.5.emmc.kresq (DONT DOWNLOAD IT, KRESCUE WILL DOWNLOAD IT FOR YOU)

1 Like

I will try Krescue as every thing else is exactly what I did already.

You can also try pressing Function key 3 times within 1-2 secs and it should enter upgrade mode to load CoreElec from the sd card.

no, tried that, it goes into a different upgrade mode. Maskrom mode.

Krescue did the trick tho so I am loaded and learning now, thanx :slight_smile:

TQVM! where every other method failed Krescue worked a charm!


Glad it worked for you. I have come to the conclusion that krescue is the ultimate tool for changing operating systems on vim3.

Same thing happened to me when i tried to flash manjaro using the sdcard, it failed spectacularly at the stage when i shifted it to emmc but when i did the same through krescue, it worked like a charm.

Keep 2 things handy,

  1. Usb burn tool plus latest android image
  2. Krescue bootable sdcard with some operating systems downloaded in its dump.

If you have above 2, you can pretty much recover your vim anytime and stay comfortable.


Can you post a mini review of Coreelec? Your experience and all aspects of the operating system…

1 Like