Disabling interlaced resolutions / Enable fractional frame-rate resolutions while still using resolution_white.xml?

Disabling interlaced 1080i, 3840x2160i resolutions

If you comment out
resolution_white.xml in /device/rockchip/common/device.mk file
then in TvSettings - Display - HDMI
it shows all the resolutions available including fractional frame-rates and interlaced resolutions.

I want to know if it’s possible to disable all interlaced resolutions like
1920x1080i@60hz, 1920x1080i@50hz, 3840x2160i@60hz, 3840x2160i@50hz,
so it only shows non-interlaced resolutions in TvSettings.
Do you know what code I can comment out to not show or use these resolutions?

I see in kernel/drivers/gpu/drm/drm_edid.c it contains lots of resolutions,
is it perhaps responsible for showing all the resolutions if resolution_white.xml is removed? What code can I comment out to disable all the interlaced resolutions?

Perhaps a different solution
Don’t comment out and still use the resolution_white.xml file and inside it make sure there are no interlaced resolutions, remove them, then they won’t show.
But then how to add all the fractional frame-rate resolutions, I don’t have their parameters to add and not sure where the kernel gets them or calculates them.
I also see in drm_edid.c there is also only a single fractional frame-rate resolution -
/* 0x58 - 4096x2160@59.94Hz RB */
Some places in the kernel, the frame-rate eg. 60hz is taken and then it’s *1000 /1001 to get the fractional frame-rate 59.94hz resolution.
How can you add the ones for
1920x1080x23.976, 1920x1080x29.97, 1920x1080x59.94, 3840x2160x23.976, 3840x2160x29.97, 3840x2160x59.94 to the resolution_white.xml file so they are used and show up in TvSettings - Display - HDMI?

resolution_white.xml file location is at /device/rockchip/common/resolution_white.xml

Regards