CPU heating issue


I was also interested in why and with android that temperatures rise with Asphalt 8 same code temperatures. I come from the use of a p30 raspberry that warms a lot and the temperatures are the first thing I control and I set up by mounting a really big heat sink , quet
These types of products all suffer from the same problem


I tried this app (CPU Thermometer), but all I get is… “Important Message: We are sorry, but CPU temperature sensor isn’t detected on your device”. Before I upgraded to V171028 from V170930 the sensor worked fine with the CPU-Z app. Any explanations? Any advice? Also, for the first few boots after upgrading, my boot screen, the Khadas screen, not the Android boot screen, was green, not black as before. Now it is black again. I want my Temperature reading to work again so I can hook up the blower fan to the fan header instead of the 40-pin header.

Device: VIM2 Max with S912, 3Gb RAM, 64Gb eMMC
OS: Android 7.0.1 Nougat_V171028


Hello, My VIM2(same config as yours) is running the same firmware. I am using this temperature app. I like it because it has an optional floating widget to overlay temp readings.
This app is displaying temperature as expected. Based on when the fan turns on, displayed temps mirror my fan settings.
CPU-Z also displaying temps.

Latest update (Nougat_V171028) stopped processor thermal reading

I don’t have either of my fans connected to the fan header, so my fan would be on permanently. What would have stopped my temperature output? Before I upgraded I had pressed all the buttons to reset the chip. I have the log from the upgrade. I erased the whole device I think before the upgrade, unintentionally, but all seems well except for the temp reading. Would it have anything to do with the Uboot I keep reading about? Or is that Linux. I’m stumped. All I can think is I need to reinstall or flash the whole device. But I want it to work so I have to do something


Hi, Rocket99:

How you erased your VIM2 device?


When I went to USB install the upgrade there was an option to check boxes in the configuration of USB Burning Tool,. and I was instructed by the OP of the pp0 only, to Erase flash, and, Erase bootloader, which were already checked by default. The Reset after success, and Overwrite key boxes were not checked and I left them that way. Been wondering, is the latest upgrade just a dirty flash update, or, is it a complete ROM?


I flashed the latest update to a VIM2 that had Ubuntu installed prior. Not sure I follow the term “dirty flash update”, but seemed a complete ROM to me. Flashing the image will erase user data, apps, and app data. I assume this is a “clean flash”. :slight_smile:

The following image shows the configuration I use to flash, some choose to go with the defaults. I make a single change. I have used both successfully, but I flash all of my AML devices with this config…


Does anyone know what to do with the blue square you get in my heatsink pack brand new and we all have learn


Paste the Thermal Paste on the CPU around area then Install the Heatsink