CPU heating issue

I am sorry, but 65°C is too high, mine is around 40°C or less in idle, it rarely goes over 60°C, it did with older Armbian images.

Your system doesn’t freeze, but you will definitely shorten Vim’s lifecycle if the temperatures are too high.

Tbh i am not even sure are these temperature measuring apps even reliable, but freezes and reboots are a sign that something isn’t right.

I thought you wrote somewhere that you tried to use 2 more different adapters, did you try to use Vim with 5V/2A adapter, if not try it, i know my advice doesn’t make sense, but i did see many solutions that looked stupid, and in the end it turned out to be a proper solution.

Hi Tommy21,

I was under the impression that the freezes were due to cpu throttling - trying to get itself cooler.
I will take some more accurate measurements using a thermometer later.

Regarding the power adapter, I only have 2.5A or 1.8A adapters.
I will try the 1.8 one just to see if it makes a difference (I know it’s below the recommended 2A), at this point I will try anything (strange or not :wink:).

Thanks for the tip!

Hello, Under 2 amps should be fine, this will depend largely on the number and type of USB accessories you have plugged to the Vim.
When it comes to power supplies, amps are important, but so to is the cleanliness of the output. Only switching type power supplies should be used.

The Vim seldom, if ever draws over 1 Amp on its own. At least from what I have seen here.

1 Like

Mine works great on 1.4A Asus adapter but reboots on Teclast 2.5A and Nokia 1.4A.

Be interesting to see the output of that Telecast power supply on an oscilloscope. :slight_smile:
Also its voltage under load.

So I did a small test with my USB meter to give you some idea. I don’t have oscilloscope and my attempts were not professional in any means so sorry if this turns out useless :slight_smile:
I’ve performed my tests with Blitzwolf cable rated at 3A with no peripherals connected (just airmouse dongle in the USB port). I was running random 1080p Youtube videos and Kodi on Marshmallow 170121. CPU temperature measured with a cheap IR thermometer was 55 degree Celsius maximum. I’m using no heatsink or fan. The hottest place on the board I’ve found was 65 degrees next to the charging port.


Very nice. Yeah, I have not owned an oscilloscope in years. But the voltage drops on the Telecast would seem to tell the tale. Good post. :slight_smile:

WOW! Loku02 that’s cool.

I didn’t get a chance to do much during the weekend other than testing more power supplies but that didn’t seem to make a difference ( I never experienced any reboots) and if the fan in on the VIM it doesn’t freeze regardless of the power adapter used
I am supposed to get a professional IR thermometer today from an electrician friend so I hope to post the true thermal readings by tomorrow.
In any case I stopped using the Teclast power adapter – too many of you seem to have issues with is.

I use Nillkin 5V/2A adapter with Vim, absolutely no issues so far with it, gearbest sells it, although i didn’t bought it from gb.

I was planning to buy Teclast adapter, now i am glad i didn’t.

Hi all,

As promised here is a pic of the thermal imager - as you can see the vim under load gets to around 62-63 degrees.

This leaves me buffeld, if heat is not the issue then what is the cause of the freezes and why do they stop once the fan is on :disappointed_relieved:

I guess ill have to wait the month untill i get the ttl to usb adaper - not happy.

Thanks again everyone!

It’s really strange, can you confirm again with this? It should be a problem if the temp is 62 degree under load.

And did you try with a new DC adapter?

Hi Gouwa,

Yes, the cpu temp gets to 62 degrees, you say this is too high under load?

And yes i tried several power adapters see pic:

Top to bottom:

  1. Asus 2.0A
  2. Lg g3 1.8A
  3. lg nexus 1.2A
  4. Lg g5 1.8A
  5. Teclast 2.5A
  6. Htc 1.0A

There was no difference between them regarding the heat (under the htc the vim was a bit strange but maybe it was too weak).

I think you definitely have a hardware issue, you received a defective board, fan will lower the temperature, the only solution is to contact the seller.

You tried 5 adapters, and Vim didn’t work properly on neither of them, i don’t see any other solution.

Based on my experiences, I’m agree with Tommy… As you confirm, the CPU temp isn’t issues, but there is as well DDR memory. It’s unfortunately native that memory chip are faulty from manufacturing (since ~15years experiences, I can tell you a lot of stories), and are sensitive on temp too. And bad for us, it’s difficult to test in ARM platform.

I’m just tried connect Linux RX/TX console and I’m see there isn’t way to access uboot.
For example, in company what I’m working for, we have kind of memtest included in uboot. Looks like that version of uboot cannot be controlled, or?

If you interest about console, you can use windows like me, the good one console program is putty.exe, speed is working under 115200bps. Power +3.3V isn’t required. But most likely you will get crash dump from kernel and you figure out, that something is wrong, what you already well know.

Oh well :sweat:

I guess I have no other option but to contact the seller – I hope they will not give me any problems replacing it.
I hate this sort of things, it is such a hassle.

I just hope the next one won’t have any issues…

If you got any problem, let us know.

And kindly take a Sticker on the VIM device, so when we got the device, we can locate & analyse the real issue and post the result here.


anche a me arrivava a 80c poi ho cencato di capire dove fosse il problema e o scperto che
temp cpu libreelec 52c
temp cpu andoid kodi CPU 82c
temp cpu android spmc 64c
tutti provati con stesso file video e per medesimo tempo
temp linux ful load 68c

Hi qaz22,

I’m not sure how accurate these reading are – that is why I used the thermal camera.
When checking android or kodi I saw temperatures of 85 degrees and on the thermal camera it was 62 degrees.

I wish there was a reliable on-board sensor, it would have made everything easier (not everyone has a thermal camera lying around…)

Touching the box between android and libreelec codes and linux the difference is felt with linux and libreelec the box and practically tepid
With android codes the box is really hot, however you can do the same test.

I asked my friend for the thermal camera again, i will do another test with libreelec over the weekend and update with the results.