CoreELEC 20.1 Ethernet DHCP Problem

Which Khadas SBC do you use?


Which system do you use? Android, Ubuntu, OOWOW or others?

CoreELEC 20.1

Which version of system do you use? Khadas official images, self built images, or others?

Official CoreELEC Amlogic image

Please describe your issue below:

Hi everyone. I’m facing a strange issue. If I install CoreELEC 20.0 with OOWOW to EMMC, boot into it, Ethernet gets a correct IP address with range 172.16.x.x as configured on my router. After some time it finds and update to CoreELEC 20.1, updates and after reboot Ethernet gets IP in 169.254.x.x range, so I can’t reach it. Setting IP manually doesn’t seem to fix the problem.

I discovered that returning dtb.img from CoreELEC 20.0 is likely to fix the problem, but I had some issues with USB after that.

Same situation happens if I install Android Pie with OOWOW to EMMC, flash CoreELEC any version (tried 19.5, 20.1) to SD card and boot (from android - reboot update and the magic happens). I tried to search the internet and some say that it’s a U-boot issue in lates Khadas Androids and one should downgrade to make CoreELEC work. I tried to downgrade to V210128 abd V200112 but nothing changed. What should I do?

I can see the same issue with Coreelec 20.1, reverting to 20 fixes it, something is def wrong with the dtb configs on 20.1