Converting official yolov3 give wrong results

Dear tech support,

I am trying to run the npu demo converting official yolov3 model before training my own. I updated sdk, app, binaries to latest version and I can compile yolov3.nb from official yolov3.weights & .cfg files. I only changed the yolov3.cfg file input width & height to 418,418 because the default 608x608 did not even load the generated model in detect picture demo. I build & copied & yolov3_88.nb to detect_demo_picture. I run the app but it takes maybe 13 sec just to run detect and the results are wrong with many persons detected as with picture attached. I followed this convert and call your own model through NPU | Khadas Documentation with dynamic_fixed_point-i8 , VIPNANOQI_PID0X88 for vim3 pro.

  • I converted --channel-mean-value to ‘0 0 0 256’ as instructed although it is not clear why

Could you give hints what is going on. why it takes very long and detect many wrong results.

I also tried to checkout version for aml_npu_sdk, binaries, app. now the setup exacly match the offical documentation. when I run the demo I get:

~/aml_npu_demo_binaries/detect_demo_picture$./detect_demo_x11 -m 2 -p 1080p.bmp 
W Detect_api:[det_set_log_level:19]Set log level=1
W Detect_api:[det_set_log_level:21]output_format not support Imperfect, default to DET_LOG_TERMINAL
W Detect_api:[det_set_log_level:26]Not exist VSI_NN_LOG_LEVEL, Setenv set_vsi_log_error_level
det_set_log_config Debug
E [model_create:64]CHECK STATUS(-1:A generic error code, used when no other describes the error.)
E Detect_api:[det_set_model:225]Model_create fail, file_path=nn_data, dev_type=1
det_set_model fail. ret=-4

for anyone facing the same issue. although I did a full system upgrade. what worked for me was reinstalling the latest 4.9 vim3 image. checked out and the converted model working fine

Hi @osos55 how did you solve this issue? I have the similar issue.

  1. Should I install the new VIM3 image? Which one?
  2. Should I install the recent libraries and requirements? and do the “sudo update”
  3. Should I clone the sdk version of and update all submodules?
  4. Should I use the recent aml_npu_app and aml_npu_binaries?
    Please help!