Convert tool is not working

I’m using khadas vim3 pro model with yolov5s_timvx. I tried to convert my weights made with python yolo (yes, I changed the structure of model and everything is correct).
The first model was with mistake (output was [1, 54, 80, 80] - I have 13 classes) and however it worked in this way

But when I’m trying the correct model (output is [1, 3, 80, 80, 18] how it should be) I’m getting the error

So what’s going on with your convert tool?
Maybe it’s my mistake, if so please let me know how to fix it…

Best wishes and waiting for your reply!

Hello ,
Which convert tool do you use ? is it right now ? i also try to convert model ,but failed .

I think it was my mistake, but this doesn’t solve my problem.
I changed the oriinal python yolo myself and got the [1, 255, 80, 80] output, it worked, but in the wrong way. Then I changed the output to the [1, 3, 80, 80, 85] and it stopped working.
As I can see he needs different dimensions.
Than I found this article:

But it’s not converting my yolov5 weights to correct ones because he doesn’t understand what are 459, 420, 381 and 167 :frowning:
Trying to find out

What is your problem?

Hi ,
I also want to convert yolov5 model , that looks the convert tool’s problem , which is not descripted clearly .
This is my problem:
It is wrong when Converting model Using KSNN conversion tool - VIM3 - Khadas Community
It seems lack file .

Do you have python yolo code?
I can maybe help out

i get the code from:

I need convert the model by KSNN and run it on NPU .

I decided not to work with ksnn, so I’m changing the model by myself. My opinion is that the guys from khadas are using Yolov5 v5.0 which I think differs from Yolov5 v7.0.

As far as I hadn’t used the ksnn, can you please describe in few words how it works?
Because what I’ve done - I made new model just changed forward method → removed sigmoid as different stuff

Hey @Frank can you help us here?