Connect camera via USB - Edge 2

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu 22.04.2 LTS

Which version of system do you use? Khadas official images, self built images, or others?

Linux Khadas 5.10.66

Please describe your issue below:

I’m trying to connect a camera via USB, it detects /dev/video51

But, once I follow the Hardware Encoding steps from the documentation I get the attached error.

Post a console log of your issue below:


Hello @3l3k10, Welcome to the community!

Does the encoder show similar clock errors with the other video device (/dev/video52) as well ?

Could you provide more details of your USB Camera as well ?


Hello @Electr1 thanks for your welcome.

This is what I get when I try /dev/video52 it doesn’t seem to recognize it as a video node.

The reference of the camera is the following: Allinko 550 FULL HD 1080P, link:

I tried the same camera with VIM4, and it worked correctly, with the following command.

gst-launch-1.0 -v v4l2src device=/dev/video0 io-mode=mmap ! video/x-raw,format=YUY2,width=1920,height=1080 ! queue ! amljpegenc ! avimux ! filesink location=videos.avi & sleep 300; pkill -f “gst-launch-1.0”

I can play the recorded video successfully. I had the intention of testing the same camera with the Edge2, to see which SBCs work better on


@3l3k10 perhaps you need to change your arguments when using the Edge2, if your webcam only support raw output instead of jpeg out you need to use image/x-raw, format=YUY2 instead of image/jpeg.