Changing OS on vim1

hi, I’m sorry if perhaps this question may sound silly, but I’m a newbie managing SoC computers;

I recently got a new “vim1” and it came with an Android OS; I’d like to work with ubuntu or armbian, so I downloaded Armbian_21.08.1_Khadas-vim1_bullseye_current_5.10.60.img.xz and flashed it on a USB stick; I then plugged in the stick and I tried to boot the board following this guide
both the Keys Mode and the MRegister Mode took me to the following screen:

from now on, I have no idea how to move between the options, since the reset button and the power button are doing what they are supposed to do, and the function button, if held just selects the already selected option ( I assume is working only as up volume ).

I also tried the via Android version suggested here, but no boot image was found.

Is there something I’m missing?
Is there any other option to install ubuntu or armbian?

thank you in advance for any help

android variant not bootable from USB by default

easy solution

  • write to SD card and try boot (still no warranty)
  • Krescue → install armbian to eMMC
  • Krescue → install mainline uboot + bootup armbian from sd or usb or nvme

You should try krescue booting and flashing the OS of your choice from there.

That way it will be very easy for you.