Cat: /sys/class/mcu/usb_pcie_switch_mode: No such file or directory

I’m trying to load my OS to a 1TB Western Digital NVMe SSD on a VIM3. I finally got Ubuntu 20.04.4 loaded to emmc from SD card and booting from emmc. When I try to follow the procedure to enable the SSD interface I get the subject line error message. Can someone please provide an updated procedure as to how to get the SSD interface enabled on the VIM3?

Lower left corner (show applications) click on the box with 9 squares, find the red and green arrow icon and open it.


select PCIe > ok

Then reboot.

Unfortunately, I’m using the server version of Ubuntu at the moment. Forgot to mention that :roll_eyes:

Install krescue onto SD and boot from that.

KBI device configure

Set port mode to PCIe

graphics will look much better on HDMI, this is from tty so I could get a screen shot.


You can follow this to setup.

how can i get so amazing tty pictures :wink: ?

1 Like

It’s alive! Awesome, I see the drive now! Now to figure out how to transfer everything to that drive and boot from it instead. I didn’t see that function in Krescue.

You cannot boot from it.

Create several partitions and permanently mount them in fstab.

Its actually a safer way to run.

Its also much easier if you have Ubuntu desktop running and ssh into your VIM3. Open 2 consoles on desktop and cut and paste uuid and related stuff.

Also c&p the current fstab line and use it except change pass to 2 on all the partitions and edit your mount points, uuid…

Gparted and a USB to NVMe adapter on a Ubuntu desktop is much easier to use when setting up the partitions instead of using CLI. Just configure all of them on desktop then move NVMe back on your VIM3 so you can get the UUID and modify mounts.

Understood. I can’t seem to have it even mounted automatically at boot. When I update the /etc/fstab file with the drives UUID, it just keeps rebooting. I may switch to an Ubuntu desktop version to make things easier.

If not post your fstab


$ sudo blkid -o list

You must be careful modifying fstab, DO NOT use any of the “internet” advice. Use the exact same parameters as the original config has.

Screen shot of proper fstab

Awesome! It’s working now! I used tabs instead of spaces between all the settings and copied all the options from the other ext4 type drive. A weird thing happened the first time around though. When I used the blkid command, it gave me a different UUID. I tried it and booted very slowly but didn’t mount the drive. I tried the blkid command again and it gave me another UUID seemingly the same length as the other ext4 drive and it mounted automatically during boot.

Should have mentioned this sooner, before reboot do:

$ mount -a

It will send an error out so you can go back and edit again before reboot.