Can't install a new firmware, it just won't let me (multiple methods attempted)

Which Khadas SBC do you use?

Vim 3 pro

Which system do you use? Android, Ubuntu, OOWOW or others?

Whatever will work.

Which version of system do you use? Khadas official images, self built images, or others?

Others

Please describe your issue below:

I’m trying to put a new system on my VIM 3 and it won’t work. I have tried the following two:
Latest Armbian for VIM3:
Armbian_22.08.7_Khadas-vim3_jammy_current_5.19.17_xfce_desktop.img

Latest Manjaro KDE Plasma for VIM3:
Manjaro-ARM-kde-plasma-vim3-22.10.img

I have tried copying the .img file on to the sd card and installing from within OOWOW on sd card, and when that didn’t work I flashed the last KRescue on to the sd card and tried in that. I have booted into both and tried this method with the same result:

IMAGE NOT SUITABLE FOR VIM3 BOARD

Even though these images are made specifically to suit VIM3 I am still met with error.

So next I tried flashing by USB, using multiple different versions of USB Burning Tool. This time I am facing this error. I have already extracted the file out of the .xz and have been trying to use the .img file but with no luck.

Parse burning image fail.
image

What is going on? Please, I just want to install armbian!

Post a console log of your issue below:



For such image, you need to write it to SD card directly. Check the documentation below:

https://docs.khadas.com/products/sbc/vim3/install-os/install-os-into-external-storage

If you want to use the USB tool to flash the image to eMMC, you can use the image below:

Desktop - https://dl.khadas.com/products/vim3/firmware/ubuntu/emmc/vim3-ubuntu-20.04-gnome-linux-4.9-fenix-1.3-221118-emmc.img.xz
Server - https://dl.khadas.com/products/vim3/firmware/ubuntu/emmc/vim3-ubuntu-20.04-server-linux-4.9-fenix-1.3-221118-emmc.img.xz

Thanks for your quick reply. Why can I not write these images to eMMC? I will try the SD Card method. I need to use armbian. Thanks

some images are made to run from the sd card solely and as such must be written to the sd card for it to work. some sd card firmware however may have a built in utility to migrate to internal storage or a ssd (if installed).

i will check situation later ! but you can check armbian installation from oowow online scripts