Can't get into upgrade mode via serial mode

Which Khadas SBC do you use?

VIM 3 Pro

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Khadas official images, self built images, or others?

Khadas official image

Please describe your issue below:


I’m trying to boot into upgrade mode via the serial mode by following the instructions here: Boot Into Upgrade Mode | Khadas Documentation

I was able to stop autoboot by pressing the space bar. However, when I run the command “run update”, I got: Error: “update” not defined. See the logs below.

Am I in U-Boot? Is the prompt supposed to be => instead of kvim# now? How come I can’t “run update”?

Thanks in advance.

Post a console log of your issue below:

U-Boot 2021.04 (Apr 29 2022 - 22:19:45 +0800) khadas-vim3                       
Model: Khadas VIM3                                                              
SoC:   Amlogic Meson G12B (A311D) Revision 29:b (10:2)                          
DRAM:  3.8 GiB                                                                  
MMC:   sd@ffe03000: 0, sd@ffe05000: 1, mmc@ffe07000: 2                          
In:    serial                                                                   
Out:   serial                                                                   
Err:   serial                                                                   
fusb302_init: Device ID: 0x91                                                   
Net:   eth0: ethernet@ff3f0000                                                  
Card did not respond to voltage select! : -110                                  
Can't set block device                                                          
Failed to load 'splash.bmp'                                                     
Card did not respond to voltage select! : -110                                  
Can't set block device                                                          
1080138 bytes read in 26 ms (39.6 MiB/s)                                        
DISPLAY: setup failsave FullHD mode                                             
starting USB...                                                                 
Bus usb@ff500000: Register 3000140 NbrPorts 3                                   
Starting the controller                                                         
USB XHCI 1.10                                                                   
scanning bus usb@ff500000 for devices... 4 USB Device(s) found                  
       scanning usb for storage devices... 0 Storage Device(s) found            
Setting bus to 0                                                                
Hit SPACE in 2 seconds to stop autoboot=>                                       
=> run update                                                                   
## Error: "update" not defined                                                  

Hello @vuonglab

The method you used only for vendor U-Boot, but you use a “mainline” U-Boot, so it may not work.
Anyway, you can try TST to enter upgrade in any situation.

Thanks, @numbqq.

I tried the TST Mode and Keys Mode many times and my VIM3 keeps booting to Ubuntu. I can’t get into upgrade mode (fastboot) to install fuchsia (Install Fuchsia on a Khadas VIM3 board).

I bought my VIM3 off eBay. Can you flash the board in a way that permanently disables upgrade mode, can you?

Thanks in advance for your help.