Cannot install LINUX on VIM1

got several problems with a 3 years old ubuntu OS on VIM1 and decided to make it fresh.

But now I am lost…

I downloaded the tool for direct EMMC installation and downloaded the Debian image.
I tried to import it into the USB-Burning-Tool … “parse error”.
This result I get by 2 Debian images and 3 ubuntu images (hope it is correct to rename the files from to xxx.img).
The VIM1 was detected successfully.
So, no success.

Then I flashed a USB Stick with the latest Ubuntu image and the VIM1 booted successfully, so far so good.
But how to transfer the OS from the stick to the EMMC?
I tried the hint on the khadas documentation pages and tried “sudo Emmc-install” and get “you have to use SD-Card”… so disappointing … :crazy_face:

Any hint for me ?

Thanks in advance


Why are you following very old methods?

Try the new kreque tool build by Khadas team.

  1. Download krescue from the download link for vim1 sd card.
  2. Flash it on sd card using etcher software.
  3. Boot into sd card on vim1.
  4. Download the needed os from the list and it follow the emmc install wizard steps.
  5. Once flashing on emmc is complete reboot with sd card removed.

It is very simple now with kresue tool.

Krescue thread


Hi Spikerguy,

thanks for your response.

The old way? It is the way I can see on the official Khadas website !?

I flashed an SD card, but it doesn’t work (?).
I booted the VIM1, but I can see only the KHADAS text, booting into upgrade mode blanks the screen and brings the text back again after a second.
ETCHER said everything flashed okay, but nothing happened.
I will take a look at the weekend … strange …

Thanks for your support


1 Like

please read howto boot Krescue if cant boot automatically


thanks for your support, but I think I have a hardware issue.

I tried different ways for booting and plugged it to a different power with different results !?

I connected it to 24W usb-power-connector and I get a stable red LED in the front.
This red LED I got the last two years with the VIM working.

Then I connected it to the USB-C from my LENOVO Notebook and got a fast flashing red LED.

ByTheWay … Please enter the new year carefully and stay healthy.