Cannot initiate Dual-boot in latest firmware

Version: VIM2_DualOS_Nougat_Ubuntu-16.04_V170818

When I reboot and hold the Function key (middle button) in. I cannot get it to enter Ubuntu.

If I boot to Android, I can find no options to boot into Ubuntu. If I hit the power button on the remote, it goes into sleep mode.

If I hold the Power button in (closest to GPIO) then eventually it goes into recovery menu.

Is this me, or is the firmware broken?

Following this:

The long press power in Android, brings up a menu and Ubuntu option is there. - This works.

The ‘function’ button I cannot get to operate.

Actually, I still would prefer that it would default the other way around - IE: always Ubuntu, with Android as the option.

Or even better - Always boot to what I selected, until I change it and then alway boot that.

I dont want to be holding buttons in and facing North every time I want Ubuntu, and stand on my head facing East for Android!

Yes,I quite agree with it. We will add support for it in next dual os release

Is this above solution provided on the 2nd post says ‘Attention: for VIM Pro model only!’ - Is this going to work with VIM2 Max model? Please Confirm…

Also like to ask another question Actually…

  1. VIM2 Max comes with Andriod preloaded at it’s Internal Memory…Right… - Can I prepare a Micro SD Card with Ubuntu Mate Image provided by the firmware page of this site and boot into that Ubuntu distro without disturbing the preloaded Andriod?

If Answer is Yes,

I think the procedure is ‘power on and pressing the Function button, will boot from the SD card’ <—Right ?

  1. Creating a Bootable SD Card for VIM 2 can I use Win 32 Disk Imager or Etcher Tools - Just what we do in Raspberry Pi ?

If anyone can show some lights regarding this matter…Please let me know. Thanks.

Multi-Boot ROM can be work with all VIM2 model and not only for VIM2 Max model

It still not support for that, but we will add support for it in the future

Yes, You can use Win 32 Disk Imager to create a bootable sd card for VIM2

Hello, With Android installed as supplied, Linux variants can also be boot and run from SD card or USB flash drive. Does not alter installed Android. Will boot to Android if USB flash drive or SD card is not connected. Insert SD card or USB flash drive to boot to Linux.
@balbes150 does much in this area. For instance, see here. But several Linux varieties are available.

I have released the new ROM VIM2_DualOS_Nougat_Ubuntu-16.04_V171028.7z.
It support for it. You can have a try.

I use your new release (171028): first boot in android, power off menu and boot ubuntu mate.
After reboot or power off always boot in ubuntu, how I can change it? I tried with function button but anything changed.
Thanks a lot

Hi gazn3vada,

You can reboot to Android from the menu(System->Reboot to Android).

Thank you @numbqq,
I added a new user to system and “Reboot to Android” is not in menu System.
You can reboot in android with command:
$ reboot_to_android


Hi gazn3vada,

You can add a menu for your new user.

  • System->Preferences->Look and Feel->Main Menu
    Select System menu, and click New Item, and add name, command and comment information.

Thanks for your help @numbqq

I own a vim2 MAX.
Just noticed that LibreElec (on SD card) - version (latest as of this day) does not boot when EMMC’s last boot was Ubuntu.
Works when EMMC is set to boot under android.
Ubuntu is still sluggish (lack of video driver) but still much more usefull than Android in my opinion.
BTW, remote still not working with LibreElec (remote.conf for VIM2 placed in /.config).
Anyway, special thanks to kszaq for his remarkable work!
Thks to you all and keep up with the good work

1 Like

Hi All,

I have to use sudo to use reboot_to_android when used in a terminal/ssh, I set an alias, like;

alias android=‘sudo reboot_to_android’.

in my .bash_aliases file.