Cannot boot balbes150 libreelec image


my Khadas VIM runs a VIM_Nougat_V180210 firmware.
I have burnt on a SD card this LibreELEC image: LibreELEC-S905_SD_USB.aarch64-17.6_20180122-KVIM.img.gz
With UpdateLocale application, I have selected then launched the Update.
It failed:

TE: 87009

BL2 Built : 20:32:17, Sep  8 2017. 
gxl g6296b83 -

set vcck to 1120 mv
set vddee to 1000 mv
Board ID = 6
CPU clk: 1200MHz
DQS-corr enabled
DDR scramble enabled
DDR3 chl: Rank0+1 @ 768MHz - PASS
Rank0: 1024MB(auto)-2T-11
Rank1: 1024MB(auto)-2T-11
DataBus test pass!
AddrBus test pass!
Load fip header from eMMC, src: 0x0000c200, des: 0x01400000, size: 0x00004000
New fip structure!
Load bl30 from eMMC, src: 0x00010200, des: 0x01100000, size: 0x0000d600
Load bl31 from eMMC, src: 0x00020200, des: 0x05100000, size: 0x0002c600
Load bl33 from eMMC, src: 0x00050200, des: 0x01000000, size: 0x00066a00
NOTICE:  BL3-1: v1.0(release):a625749
NOTICE:  BL3-1: Built : 11:25:15, Aug 25 2017
[BL31]: GXL CPU setup!
NOTICE:  BL31: BL33 decompress pass
[Image: gxl_v1.1.3243-377db0f 2017-09-07 11:28:58 qiufang.dai@droid07]
e9 e5 f6 34 8a ed 3 ed fd f4 86 fb [0.314747 Inits done]
secure task start!
high task start!
low task start!
ERROR:   Error initializing runtime service opteed_fast

U-Boot 2015.01-g2735815 (Feb 10 2018 - 11:59:11)

DRAM:  2 GiB
Relocation Offset is: 76eaf000
register usb cfg[0][1] = 0000000077f56b30
[CANVAS]canvas init
boot_device_flag : 1
Nand PHY Ver: (c) 2013 Amlogic Inc.
init bus_cycle=6, bus_timing=7, system=5.0ns
reset failed
get_chip_type and ret:fffffffe
get_chip_type and ret:fffffffe
chip detect failed and ret:fffffffe
nandphy_init failed and ret=0xfffffff1
MMC:   aml_priv->desc_buf = 0x0000000073eaf6b0
aml_priv->desc_buf = 0x0000000073eb19d0
SDIO Port B: 0, SDIO Port C: 1
emmc/sd response timeout, cmd8, status=0x1ff2800
emmc/sd response timeout, cmd55, status=0x1ff2800
init_part() 293: PART_TYPE_AML
[mmc_init] mmc init success
dtb magic edfe0dd0
start dts,buffer=0000000073eb4200,dt_addr=0000000073eb4200
parts: 10
00:      logo   0000000002000000 1
01:  recovery   0000000002000000 1
02:       rsv   0000000000800000 1
03:       tee   0000000000800000 1
04:     crypt   0000000002000000 1
05:      misc   0000000002000000 1
06:      boot   0000000002000000 1
07:    system   0000000080000000 1
08:     cache   0000000020000000 2
09:      data   ffffffffffffffff 4
init_part() 293: PART_TYPE_AML
eMMC/TSD partition table have been checked OK!
check pattern success
mmc env offset: 0x27400000 
In:    serial
Out:   serial
Err:   serial
[store]To run cmd[emmc dtb_read 0x1000000 0x40000]
_verify_dtb_checksum()-917: calc a15de243, store a15de243
_verify_dtb_checksum()-917: calc a15de243, store a15de243
dtb_read()-1039: total valid 2
dtb_read()-1106: do nothing
vpu: clk_level in dts: 7
vpu: set clk: 666667000Hz, readback: 666660000Hz(0x300)
vpu: vpu_clk_gate_init_off
vpp: vpp_init
[1080p60hz] is invalid for cvbs.
set hdmitx VIC = 16
config HPLL = 2970000
HPLL: 0xc000027b
config HPLL done
j = 4  vid_clk_div = 1
hdmitx: set enc for VIC: 16
HDMITX-DWC addr=0x10004006 rd_data=0x40
Error: HDMITX-DWC exp_data=0xff mask=0x9f
rx version is 1.4 or below  div=10
hdmtix: set audio
hdmitx phy setting done
Net:   dwmac.c9410000amlkey_init() enter!
[EFUSE_MSG]keynum is 4
[BL31]: tee size: 0

Start read misc partition datas!
info->attemp_times = 0
info->active_slot = 0
info->slot_info[0].bootable = 1
info->slot_info[0].online = 1
info->slot_info[1].bootable = 0
info->slot_info[1].online = 0
info->attemp_times = 0
attemp_times = 0 
active slot = 0 
[OSD]load fb addr from dts
[OSD]fb_addr for logo: 0x7f851000
[OSD]load fb addr from dts
[OSD]fb_addr for logo: 0x7f851000
[CANVAS]addr=0x7f851000 width=3840, height=2160
amlkey_init() enter!
amlkey_init() 71: already init!
[EFUSE_MSG]keynum is 4
[BL31]: tee size: 0
[KM]Error:f[key_manage_query_size]L507:key[usid] not programed yet
[KM]Error:f[key_manage_query_size]L507:key[mac] not programed yet
[KM]Error:f[key_manage_query_size]L507:key[deviceid] not programed yet
saradc - saradc sub-system

saradc saradc open <channel>            - open a SARADC channel
saradc close    - close the SARADC
saradc getval   - get the value in current channel
saradc get_in_range <min> <max> - return 0 if current value in the range of current channel

gpio: pin GPIOAO_2 (gpio 102) value is 1
Product checking: pass!
Set Addr 10
Get DT cfg
Get DT cfg
set CFG
Get str 300
Get str 300

What should I do?


Firmware in a stock state or you in it something already changed (established packages , changed settings, etc.)?
What SD card is used (size) ?

Fresh firmware install -> stock state

I tried with a 4 GB SD card and a 16 GB SD card.

I used Etcher to burn the SD cards on MacOs.
And a Win10 virtual machine to flash the Android firmware.

This is weird. For several months there were more than 100 downloads of the image and no one complained about this problem. Try running the update from the UART console. Run the command

“run recovery_from_sdcard”

I have seen many messages that images are not recorded correctly in this mode. Look at the topic about LE, there is a description about it and how people solved the problem.

run recovery_from_sdcard

It worked. Then I chose in the Kody PowerOff menu: Reboot from instal to EMMC.

The first time, the install didn’t work. The second time it did.

Thank you for your help and your work.

If the media has “dtb.img”, then first install in the eMMC there is replaced by the dtb, the new version (the new "dtb.img " is written instead of the previous one in eMMC). Description of the layout of the partitions in the eMMC in the new dtb, may not coincide with the description in the dtb, which was in eMMC. Therefore, if you encounter startup problems after installing into the eMMC, you must perform a re-installation (without changing the “dtb.img”), what would reinstalling the recorded data in the correct sections.