Burning Tool no Device

I don’t know if that mSD will have U-Boot files on it.
I can’t help you anymore as i don’t know any other method to try, and without serial console cable log this would be even harder.

And also i don’t have non-Pro version, and i guess there is something else different then eMMC 16GB and WiFI card. But I don’t work for khadas so i really don’t know internal stuff.

The differences to the Pro and Non-Pro shouldn’t play effect here. I will get a TTL Serial cable tomorrow and spend another $20 on this project.

Thanks for trying to help though I appreciate it

Hello, Serial to USB adapters can be found for much less. For instance, Geekbuying has a unit for about $2(USD) that is sold for the GeekBox but works for others too.
I know you guys are frustrated, I think a solution will be found. :slight_smile:

That to much for an USB Serial Console cable
I bough my 2 years ago and payed 9$, but for sure there are cheaper ones

I live in South Africa and waiting another 2 weeks just for a cable is ridiculous. If I knew it was this crappy to update the VIM I would have ordered the TTL cable as well

@gcvanasel maybe @barhom have such cable and can test before you buy one yourself. I am not sure if that cable will help you update your VIM but for sure it will tell us more info what is going on.

So basically what you are telling me is that the TTL Serial Cable will only provide us with Information? I will not be able to alter the device in any way? So I am wasting money on a bricked endless money pit here?

@gcvanasel If you check my post 75 the second part you will see that the boot process can be stoped and writing “run update” command in “kvim#” will bring my VIM Pro in upgrade mode.
I am however not sure what you would be able to do with your VIM!

Yeah I am just frustrated I apologize for the drama and thank you all for the great support. I just can’t get my head around this one. I will definitely get a Serial cable tomorrow hopefully we can solve it then


I have successfully upgraded my device now to the Nougat version using the SD CARD method.
I did not have to do anything to enter “UPGRADE MODE”.

@gcvanasel try to follow these steps, they might work for you

  1. Plugin your sdcard into some sdcard reader to your pc
  2. Open the Burn Card Maker program
  3. Check the “To partition and format”, choose the correct image and press make.
  4. Plugin the SD Card into the vim khadas and plug in HDMI
  5. Power up and it should start to upgrade automatically (because your eMMC is erased)


This does not answer why I was unable to enter “UPGRADE MODE” using the other methods such as “Press and hold power, press reset and release power after a few seconds”, MRegister Mode(Maskrom Mode), or erasing the eMMC.

I will try to see if USB Upgrade tool can detect my khadas tomorrow again.

1 Like

@barhom I am glad that method worked for you I have tried multiple times and multiple ROMS with no luck. What size and make is your sd card? I will buy a new sd tomorrow my sd card is old and might not function correctly. I’ll also buy a Serial cable tomorrow.

How long did it take to update?

I got this this image while updating. It took about 5 minutes.
I have tried again to enter “UPGRADE MODE” for the USB Upgrade tool with no luck.

@barhom do you have any Serial to USB Cable to check what is wrong there. Does it enter into recovery as before for you?
If you are still on Android 6 maybe you can reboot into upgrade mode over adb, with Android 7 image the adb does not work

Hi All,

Ok so I just received my Serial to USB cable and 16gb Class 10 Nitro micro SD card. I booted into Linux so that I can do whatever anyone here can offer to help.

Holding thumbs

Hi All,

Finally updated to and now my VIM is usable again. Seems like there was a problem with my SD cards I used. I would recommend not using under 4gb for the update.

Thanks for all the support through out this crazy 3 days. At least I have all the right equipment for any future issues so that you all can better assist me.

Thanks to @Gouwa, @Terry, @vrabac, @barhom, @RDFTKV, @Tommy21, @Cimmarron


@gcvanasel well you could try to connect USB to TTL Serial Cable and check why it does not enter into upgrade mode with pressing right buttons. This information may or may not help Khadas support to fix that or guide how to solve it.

Follow this Khadas docs
USB to TTL Serial Cable

and then check if this method works for entering upgrade mode

for my USB to TTL Serial Cable i followed this guide written from shop where i did ordered. And i am using Windows 10 and putty tray for this.

Hi @vrabac,

Thanks I managed to connect through C-Kermit like @Gouwa posted here http://docs.khadas.com/develop/SetupSerialTool/ I would have tried PuTTy if that didn’t work.

I am about to try and update the latest Nougat and Ill try and update through USB-C and post my findings thanks for the help

Step 3 of serial-modefor-developers is than any keys on the remote side or any of the buttons on VIM. Might be a stupid question just want to make sure

On your keyboard, inside that Serial console application (c-kermit in your case).

In log is written: "Hit Enter or space or Ctrl+C key to stop autoboot: "

And serial console is not just for upgrading, it will give you information about boot process and everything. if you dont press any keystrike it will boot normaly and give you bunch information over console .

with this new ROM here “reboot update” works to (VIM is in upgrade mode)

C:\platform-tools>adb shell
kvim:/ $ su
kvim:/ # ^D
kvim:/ $ reboot update

serial console log:

[ 665.949830@2] fb: osd[1] enable: 0 (surfaceflinger)
[ 934.535068@2] SysRq : Emergency Remount R/O
[ 934.545611@3] EXT4-fs (mmcblk0p13): re-mounted. Opts: (null)
[ 934.553064@3] EXT4-fs (mmcblk0p3): re-mounted. Opts: (null)
[ 934.554065@3] EXT4-fs (mmcblk0p8): re-mounted. Opts: (null)
[ 934.558591@3] Emergency Remount complete
[ 934.639553@0] avmute set to 2
[ 935.953238@2] aml_snd_card: no audio pin_ctrl to shutdown
[ 935.954266@0] vdin_drv_shutdown ok.
[ 935.956582@0] vdin_drv_shutdown ok.
[ 935.961867@0] fb: osd_shutdown
[ 935.963125@0] sysled: module shutdown ok
[ 935.967160@0] reboot: Restarting system(init) with command ‘update’
[ 935.974079@0] reboot reason 3