Burning Tool no Device

Hi All,

I am trying to upgrade via the Burning Tool through USB-C. I followed the instructions and boot my VIM into Recovery yet the USB Burning tool is not recognizing the device. It did install that World Cup drivers and my version according to the downloaded zip file is v2.0.8 yet when viewing about in the Burning Tool it states v2.0.7.2.

Please help

hi, Christiaan:
Can you describe the steps you did with more details so we can better understand the problem you met. Regarding your issues, following information would be helpful:

  • The Windows OS version?
  • Is it the first time you do upgrade for VIM?
  • A screenshot of your desktop with the upgrade tool
  • A photo of VIM device
  • Others

And kindly follow the instructions and check the steps then try it out again: Upgrade Using a USB-C Cable.

Good luck!

Did you connect the usb 2.0 end of the type-c cable to your win pc, usb male to usb male cable is used for powering when you are upgrading Vim.

It does not work the other way around, if you haven’t followed instructions completely it won’t work.

It looks a little sloppy, but it won’t work in any other way, hope it helps, look at khadas docs and upgrade via usb type-c.

Hi gcvanasel.
Try this.
Open burning tool, conect usb-c to vim, Press Vim power key without release then conect usb to PC

1 Like

Geez what great response,

I will try and give more info and answer all questions in same reply:

@Gouwa - I tried on 2 laptops both with Windows 7 Professional. Yes this is my first Khadas device although not my first Android device. I have done Firmware upgrades through ADB on MXQ boxes and Sony Experia devices. I followed exactly those steps from Upgrading Using a USB-C Cable

@Tommy21 - When you are referring to powering through male to male is this necessary? As my VIM device does power on it is just not picked up . I only used the USB type-C cable to connect to the PC.

@Cimmarron - Thanks for the suggestion I will try this as soon as I can.

Unfortunately I cannot take a photo at this moment

Thanks for all the help

In my case, extra power was needed, so i did use usb to usb cable to power Vim, i believe your case could be the same.

@Tommy21 - I do not currently have a USB-A to USB-A cable yet I do have a USB adapter that might be sufficient. I read somewhere today the specs required for the outputs. I will check if the extra power might do the trick

Edit: Nope my usb adapter seems to be problematic. I will have to buy a USB-A to A by the looks of it

I just have a question, what seems to me as common sense. How would I need the extra power if the VIM already powers up? What is the indication that additional power is required?

Hello, I don’t have Windows 7, but I do have a PC with Vista, so should be similar. I have not had any issues flashing from the OTG port(USB-C). The thing that seems critical for me, is how long the Power button is held after pressing and releasing the Reset button. I find when I actually count the seconds, Vim is recognized every time.

Sometimes it is a good idea to turn off the Windows PC’s USB port power saving mode.

On a different device, uninstalling the World Cup driver, restart PC and re-install driver, helps.

Hope you get it going.


Thanks for the reply,

I just want to rule out any possibilities before buying a USB-A to USB-A cable cause I have phoned around and they aren’t easy to find in South Africa. The box does power into Restore mode if that is what you are referring to and I have tried so many times with different time frames of releasing the power button that by now it should have picked it up. I have tried uninstalling the drivers with no luck although I have not tried disabling the power saving mode on the USB ports <= Thanks for the suggestion.

If anyone has some other solution they can think of please share and thanks to you guys that have already commented.

Is your HDMI cable connected to VIM when switching into upgrade mode? I did have had problems doing this on my Dell E7470 notebook, but after connecting HDMI to VIM and LCD Monitor i was able easily to track what I am doing and did successful entered upgrade mode. I did this on Windows 10 Enterprise!

Also check Device Manager if there is any triangles on Hardware found, here i have an entry with “libusb-win32 USB Devices” and below it is the “WorldCup Devices” with driver version . This version however does not have anything to do with Burning Tool version which is 2.0.8.

@vrabac Yes it is connected that is how I know that the VIM is in deed in Recovery mode. Not sure but it doesn’t seem like the the Computer is seeing it at all. I tried different USB ports to rule out a hardware issue yet nothing. Not even a device comes up in device manager

Does it boot normaly with power supply? If connected to PC whole time and with Android there should be new storage found once booted. I can test that tonight.

It seems to boot normally when connected although there were no hardware found. I tried on 2 pc’s and the one is fairly clean (New Installation). Perhaps I should try and switch on USB Debugging and see if that helps although in Update Mode Android isn’t even booted up

@gcvanasel it seems that you still stuck on the problem.

Can you take a photo on both the VIM and PC for us? I think things will be more easy as the photo will comes with more details or information than text sometimes.


Hi @Gouwa yes still stuck, I am not currently at the VIM so will post photo as soon as I can. Hope for the best have a few new things to try so lets see how it goes

Just to rule it out, you pluged usb-c to VIM and then other part to pc?
My notebook have also usb-c ports but that way should not be used.

Yes USB-C into VIM and USB-A to the PC

I found a USB-A to USB-A cable to when I get home I will test with the extra power as well

Still no luck, I follow all instructions with the extra power and USB power saving disabled. I also tried what @Cimmarron suggested by holding power button and then connecting. Nothing working, VIM powers up and goes into Recovery mode yet PC not picking up any device