Building VIM1S image with FENIX fails

Which system do you use? Android, Ubuntu, OOWOW or others?

Debian buster and Ubuntu, both result with the same error

Which version of system do you use? Khadas official images, self built images, or others?

Self built

Please describe your issue below:

Building a server image with FENIX (today’s 1.1.2) for VIM1S fails:

Build log error:

In file included from drivers/gpu/arm/midgard/mali_kbase_cache_policy.h:29,
                 from drivers/gpu/arm/midgard/mali_kbase_cache_policy.c:26:
drivers/gpu/arm/midgard/mali_kbase.h:48:10: fatal error: uapi/gpu/arm/midgard/mali_base_kernel.h: No such file or directory
   48 | #include <uapi/gpu/arm/midgard/mali_base_kernel.h>
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[5]: *** [scripts/ drivers/gpu/arm/midgard/mali_kbase_cache_policy.o] Error 1
make[4]: *** [scripts/ drivers/gpu/arm/midgard] Error 2
make[3]: *** [scripts/ drivers/gpu/arm] Error 2
make[3]: *** Waiting for unfinished jobs....

Hello @gkkpch

Please update latest source code from GitHub.

It should be 1.2.2, I checked on my side, it works.

Re-cloned, now it works. Thanks!

I try with fenix to build a debian distribution for VIM1S but I have this error:

cp: cannot stat ‘buster/arm64/VIM1S/*’: No such file or directory
make: *** [Makefile:2: all] Error 1

I use fenix docker.

Thank you for your help

Hello @Ludo91

Please update fenix and try again.

$ SKIP_HEADER_DEB=yes make

Hello @numbqq

always the same issue…

Info: Installing linux-image-amlogic-5.4_1.2.2_arm64.deb in chroot…
dpkg-deb: error: archive ‘/root/linux-image-amlogic-5.4_1.2.2_arm64.deb’ uses unknown compression for member ‘control.tar.zst’, giving up
dpkg: error processing archive /root/linux-image-amlogic-5.4_1.2.2_arm64.deb (–install):
dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
make: *** [Makefile:2: all] Error 1

Sorry, not the same issue, but rather an unrecognized compressed file format problem…

best regards

It’s because debian buster doesn’t support zstd compressed debian package.

To fix this, you may need to build on Ubuntu 20.04, you can try to build in docker container.

I use fenix docker, found here GitHub - khadas/fenix: One-stop script set to build Ubuntu/Debian images

should I use another one?

no it doesn’t work better!

Hello @Ludo91

Here is a test image for you.


How to install: VIM1S Install OS into eMMC via USB Flash Tool [Khadas Docs]

1 Like

Hello and thank you,

two remarks:
there is no tools directory for the VIM1S on the Khadas server, I used that of the VIM4.

I managed to flash the EMMC with your img, but when I start the VIM1S, OOWOW starts in RESCUE mode.

So I tried to flash with OOWOW your img, but when it tests the img I have a message “IMAGE NOT SUITABLE FOR VIM1S BOARD”

I’m sorry

best regard

Sorry, you can get it here:

You need to flash the image with the usb tool above, this image is not for oowow installation.


I reflash a second time in USB and Debian started!?!

Thanks a lot!

could you explain to me how you did it, please, because I tried FENIX SCRIPT in an UBUNTU 18, 20 and 22 and in the FENIX DOCKER and I never managed to do what you managed to do ?

best regard

Hello @Ludo91

Nothing special, just use a Ubuntu 20.04 host and build with command SKIP_HEADER_DEB=yes make.

then you definitely have an ubuntu 20.04 special!
because with a freshly installed ubuntu 20.04 updated and upgraded and the option SKIP_HEADER_DEB=yes make
it didn’t work for me!

I would like an img of Dietpi OS, do you think I could manage it?

There is no support at this moment.

hello @numbqq,

there is Krescue for VIM1S?

best regards

Hello @Ludo91

VIM1S is preinstalled with OOWOW aka KRescue before.

You can check the user manual about it.

I’m sorry but I couldn’t find how to enter Krescue in Woohoo!
can you help me, please?