Broken bootloader

I tried to use the update tool from the 5.5 Ubuntu image to update the bootloader after getting the corrupt screen issue, and now my VIM3 can’t boot SD Cards and is booting an ancient U-Boot from an unknown, unclearable location; how do I fix this, because as it is, it’s bricked. (And there’s no eMMC boot image for the 5.5 kernel, only the ancient 4.9 vendor kernel.)

Use the maskrom reset (short pins) to prevent emmc boot so you can either get the device connected to a PC where you can re-flash aw working image using Amlogic Burning Tool, or to boot from an SD card with working u-boot where you can dd a new image to the internal storage.

NB: Self-building mainline u-boot isn’t hard and VIM3 is supported.

The problem is that trying to boot from an SD Card doesn’t work; it just keeps failing and resetting itself in a loop. The image is the 5.5RC kernel Ubuntu from Khadas so it should work, but it doesn’t.

I’ll have to figure out how to clear whatever is on the eMMC from being able to boot so I guess it’s either put self-built U-boot on SPI then switch boot location or fiddle with MASKROM mode and try to wipe it from there.

Try krescue its special for rescue system
Easy write erase emmc and spi bootloader

How to clear eMMC is here.

I cleared the eMMC and now I get this when trying to boot krescue:

bl2_stage_init 0x01
bl2_stage_init 0x81
hw id: 0x0000 - pwm id 0x01
bl2_stage_init 0xc1
bl2_stage_init 0x02

no sdio debug board detected 

TE: 281056

BL2 Built : 19:22:01, Jul 31 2019. g12b ge9a9000 - zhiguang.ouyang@droid07-sz

Board ID = 8
Set A53 clk to 24M
Set A73 clk to 24M
Set clk81 to 24M
A53 clk: 1200 MHz
A73 clk: 1200 MHz
CLK81: 166.6M
smccc: 000493ca
DDR driver_vesion: LPDDR4_PHY_V_0_1_18 build time: Jul 31 2019 19:21:56
board id: 8
Load FIP HDR from SD, src: 0x00010200, des: 0xfffd0000, size: 0x00004000, part: 0
sd/emmc cmd 17 arg 0x00000081 status 01ff1000
sdio read data fail
FIP HDR CHK: 0x000000ff ADDR 0xfffd0000

and it just loops like this.

However, the Ubuntu 5.5RC1 image now boots properly, so, solved.

looks like u write wrong krescue image to sd (all vim board have diff bootloader and we need write proper image)

It had booted before, and I used it to wipe the eMMC (specifically, the bootloader segment mmcblk2boot0), it was after that it didn’t boot, but the Ubuntu image did start booting. Not sure what happened, but things are essentially resolved, so thank you for the suggestion to use krescue!