Booting OS from SD / USB + embedded OOWOW issues

Which Khadas SBC do you use ?


Which system do you use? Android, Ubuntu, OOWOW or others ?


Which version of system do you use? Khadas official images, self built images, or others ?

Official BUT i would like to try LibreELEC

Please describe your issue below :

If i am not wrong, booting order is SD, then USB and finally EMMC. Embedded OOWOW seems to be missing but i flashed it to an SD and i can boot with on SD or USB (through USB SD adapter). Key combo to boot it does not work and SD OOWOW tells me that SPI is empty. Also, blue LED does not turn on when SBC is turned off. I am sorry if my answer is already somewhere in this forum or elsewhere BUT i extensively searched to find an answer to these issues AND i found partial answsers …

IMO, LibreELEC images, for example, cannot boot from SD or USB OOTB because i do think that something is missing when flashing device generic or device specific images with etcher because when i flashed OOWOW to SD via etcher, it worked at first try !

Do third party images need modifications before being bootable from external storage ? I downloaded and installed Amlogic Flash Tools in a W10 VM … which tool should be helpful in my case ?

What should be in SPI ?

Finally blue LED do not shine anymore, any way to restore that please ? I already done a MCU reset to default because i read somewhere in this forum that it could restore that behavior BUT my main issues are external booting of third party images AND missing embedded OOWOW.

Post a console log of your issue below :

I would do it if it is helpful and if you tell me which one you want …

Finally, i would like to say that is my first KHADAS product and i am very satisfied :+1: BUT it is more complicated to use it compared to my HARDKERNEL SBCs i think …

PS : is a 10W DCIN is sufficient for the VIM3L ?

Thanks for your help,


Hi @kuroiTinu, welcome to the community.

VIM3L does not come preinstalled with OOWOW yet, it must be manually installed.
Refer here: OOWOW SPI flash install

Are you sure it has completely turned off ? Either the power may have been disconnected or it has only partially turned off, system just disabled other status LEDs.

LibreElec images must be either flashed to the eMMC to boot, you need to copy it to the OOWOW image dumps partition, and flashed onto the eMMC.

alternatively you can put OOWOW on the SPI flash or Install the mainline bootloader onto the SPI flash from the advanced settings or from OOWOW terminal please run, spi_update_uboot online -k

Does it also happen in OOWOW ? is the LED not turning Blue when shutting it down ?

serial console logs from the linux UART pins, VIM3/3L Setup Serial Debug Console [Khadas Docs]

Yes, for VIM3L 10W PSU can be enough.


1 Like

Hi @Electr1 and thanks for the detailed answer :+1:,


Blue LED is not entirely disabled because when shutting power off from SD / USB OOWOW then blue LED is blinking …

I will test that out ASAP, thanks.

Great :grinning: BUT in which case DCIN must be higher ? VIM3L can handle up to 20W …

Best regards

Please provide a video showcasing this behaviour if possible.

If you plan on using external hard disk or SSD, higher wattage PSU is recommended to accommodate the extra load from those accessories.


1 Like

I will do it ASAP :wink:.

I’ve just installed latest uboot to SPI like you suggested AND latest stable LibreELEC to eMMC too :+1: BUT is there a way to install OOWOW to SPI because upgrade packages do not exist for my SBC … maybe i could make one upgrade image from a standard one (the one i am using to boot OOWOW from SD for example …) by using BurnCardMaker from Amlogic Flash Tool v6.0.0 package ?

And still no clue about how to boot OS from SD / USB like OOWOW do … i found file … could it help ?

Have a nice day and thank you for your help.

I’m not a huge fan of vendor provided bootloaders in SPI as they tend to contain whothefcukknowswhat patches and complicate distro support. If you erase SPI and eMMC the default Amlogic SoC boot flow means the board will boot from SD card where you can run tests. Or if you want to install to eMMC, login via the SSH console and (re)download the VIM3L .img.gz file to /storage and write it to eMMC using “emmctool w /storage/.img.gz” and once the writing is complete, reboot to run LE from the eMMC storage. I’d suggest using as this image is using u-boot 2023.10 (LE12 nightlies will be using that from tomorrow). Also note that current LE images will not handle media over 1080p due to the current rather imperfect state of hardware decoding on newer Amlogic SoCs.


Hi @chewitt, i will proceed as you suggested. Thanks for involving yourself into this thread :+1:.

I will upgrade using emmctool :wink:.

I really hope that dev cycle of LE 12 is going well.

Anyway thanks,


EDIT 1 : if i understood you correctly @chewitt, i must erase SPI and eMMC, then boot the suggested image from SD and then use emmctool to write it to eMMC … correct ? The thing is am not able to boot OS from SD / USB, apart OOWOW image :confused:

EDIT 2 : @Electr1, the blinking blue LED when powered off my SBC after exited OOWOW, only happened once, when resetting the MCU to default values AND i do not remember if it has already be on when the SBC is powered off …

Huge thanks to you two.

I flashed your image to SD using etcher and it booted fine but there is an issue with volumes labels because after having resized /storage and rebooted, kernel cannot find /storage partition because it complains about missing storage label …

Should i add UUIDs instead ?

Thanks !

EDIT : i tried ‘box’ image from your testing repository because it has UUIDs … nothing changed, i get into rescue shell at SD boot :sob:. /storage does not contain a valid partition table …

Just install, reboot, let it fail, then cycle power and it work fine on the second cycle. I’m not sure what the issue is yet, but it affects a variety of images not just Amlogic.

1 Like

Yes, power recycling did the trick :smile:, thanks !

Here is the link for a 5s video showing blue LED blinking after a MCU reset :

Now, should i unplug DCIN before booting up again ?


In case it’s relevant: LE runs this script via systemd on boot to disable heartbeat LEDs on Amlogic boards because constantly blinking lights are annoying when watching movies in a dark room:

Running systemctl disable ledfix && systemctl mask ledfix && reboot will restore the annoying heartbeat indicator.


Hi and thanks for your assistance and your interest in my issues. I will keep an eye on that script BUT i do think that the root of all i described here with my VIM3L is a little bit more bad than just restoring stock LEDs behavior : by the way blue LED is controlled by the bootloader if i am not wrong, i must enter into it and then restore the blue LED on when powered off through KBI commands; red and white ones are controlled by the CPU and they are still working : red is off by default and white is always on by default when running OS AND it is easily customizable inside it AND different between OSes.

Thanks for your answser :+1:

I do think that i will start another topic in the OOWOW section because this rescue software is very well designed and could be handy if it do what it supposed to do … AND i think that my issues have been triggered my an OOWOW script failure. I did a reset to factory default mode … it went well until blue LED blinking when powered off after the script end because i was supposed to eject SD and boot back into OS WITHOUT DCIN out and i tried everything : remote, key combinations, even ssh to power on my device again after that script was done : nothing worked, so i DCIN out and in again after 5s and OS boot up properly BUT, the is a big BUT : i loose : blue LED + KHADAS boot logo when booting from eMMC and my guess is that the OOWOW script mentioned above failed and that failure caused side effects … i do not not know if i should more concerned about those because my SBC is still working well.


→ working for me : wizard :+1:, uboot installation to SPI and almost all scripts …
→ not working for me : oowow installation to SPI in order to have it embedded, along with uboot into SPI and boot from SPI ! When i press ‘okay’ to flash it, oowow disable network each time before checking system updates AND then nothing can happen !!!, it could not be written to SPI through oowow BUT if i have the proper spi_update or spi_flash command maybe i could workaround this like @Electr1 told me for uboot installation to SPI … device info returns SERIAL NUMBER NOT SET and sometimes v12 or v14 for HW revision, it depends … SPI uboot info returns NOT RECOGNIZED, although it is in SPI …
→ command line should be helpful in my case but i need the assistance of KHADAS team, i do not know which command to run and i do not want to make the situation badly than it is ATM !

With that said @hyphop + KHADAS done a great job with OOWOW BUT there are inconsistencies from one board to another one i think ATM…

Anyway, i really like my VIM3L, it is very well designed and bricked resistant :wink:, and OOWOW is good but has issues with my board sadly :sob: It is a nice piece of work anyway :+1:.

Thanks for any further assistance,


SPI feature to bootup OOWOW from SPI officially presented only for VIM4 VIM1S Edge2

VIM3L same must works but with some limitation

  • RESET + KEY_FN - no supported
  • for boot up from SPI need setup it 1st for example from same oowow
1 Like

PS: VIM3/VIM3L spi oowow images was removed from dl server (before it had some bugs, at this problem problem was solved), we restore it again :wink: please check

1 Like

Hi and thank you for your answers :+1:, i’ll wait then…

PS : i was having PSU issues too…changed it and now SBC is booting after u-boot update / write to SPI or eMMC.