Boot to Command Line. Not desktop environment

Which system do you use? Android, Ubuntu, OOWOW or others?


Please describe your issue below:

Any idea how to boot to command line. I tried seeing options in OOWOW but I did not see any for booting to command line. I have a auto-script I need to run when booting and I don’t need a HDMI(desktop environment ). Please Help.

Hello @MonkeyDLuffy

Please use OOWOW to install the server image which don’t have the desktop environment.

Is this the only option? To install a server image. If I go this route would I have to reinstall all my python packages and rewrite my code into this server image?

Hello @MonkeyDLuffy

If you don’t want to reinstall the image, you can try to disable gdm service so that you can only boot to command line.

$ systemctl disable gdm3
$ sudo reboot

How do I re-enable gdm3? I tried using systectl enable gdm3 but it doesnt work .

Synchronizing state of gdm3.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable gdm3
The unit files have no installation config (WantedBy=, RequiredBy=, Also=,
Alias= settings in the [Install] section, and DefaultInstance= for template
units). This means they are not meant to be enabled using systemctl.
Possible reasons for having this kind of units are:
• A unit may be statically enabled by being symlinked from another unit's
  .wants/ or .requires/ directory.
• A unit's purpose may be to act as a helper for some other unit which has
  a requirement dependency on it.
• A unit may be started when needed via activation (socket, path, timer,
  D-Bus, udev, scripted systemctl call, ...).
• In case of template units, the unit is meant to be enabled with some
  instance name specified.

Hello @MonkeyDLuffy

Can you try this?

$ sudo systemctl set-default
$ sudo reboot

sudo dpkg-reconfigure gdm3 This one worked for me to enable it again.

So by disabling gdm3 a boot autoscript program can run without desktop( being connected through hdmi)? Also when I disable the gdm3 it prompted for the user login in the command line even though I have enable auto-login. Any ideas?

Enable command auto-login, please check:

How would I revert this setting ?

Hello @MonkeyDLuffy

Try the steps below:

cd /tmp
sudo cp /tmp/serial-getty@.service /tmp/getty@.service /lib/systemd/system
sudo reboot