Boot something different than Android on original Vim 1

Hi there,
i have a quite strange issue with my Khadas Vim 1 i had lying on the Sheld for quite some time.
Now i have a use for it but i cant manage to boot something different than the Android which is on the eMMC.

So i know the Board works. Tried to boot OOWOW, Ubuntu (from the Khadas DL) or Armbian flashed onto different micro SD’s (with etcher and dd) holding various documented combinations of the function button etc without luck.

Tried to flash it with aml-flash-tool after getting it into DL Mode using the serial console method, but aml flash tool always dies at unpacking the image (aml-flash-tool --soc=gxl --wipe --parts=all --img=/home/Downloads/vim1-ubuntu-22.04-server-linux-6.1-fenix-1.4-221229.img )

The Board is a Rev 1.2 Khadas Vim 1, which also only shows me a red LED.

Am i doing something obviously wrong here?

Hi @darkside40

The images to use for the aml-flash-tool have to have the emmc marking.
eg. vim1-ubuntu-18.04-xfce-linux-4.9-fenix-1.1.1-220725-emmc.img.xz

Can you try this image ?

no need to use the function key, use the power and reset keys.


Great, thanks for the hint with the emmc marking.
After unpacking the image i was able to burn Ubuntu on the emmc.
After that also the microSD with OOWOW was able to boot.

Now i have to see how to get Armbian to work. Simple dd a microSD with the latest armbian Bookworm Release does not boot.

Tried to install it via the OOWO Online Scripts but they fail with an Error 1. Also they are not up-to-date because Bookworm is missing.

okay managed to get Armbian installed to emmc via oowow.

But one question left: why didnt it boot from SD (no matter what i did) as long as Android was on the eMMC?

@darkside40 that is a feature of the android bootloader itself, it’s primary boot volume is only the eMMC, but with linux image it can be anything.


That means that the decumentation should be extended like:
If you want to boot anything from SD etc. you have to flash a linux image first using aml-flash-tool?

@darkside40 it can still boot from external media, it just requires the right key combinations to trigger the bootloader to check SD/USB…

Perhaps your timing of the key combination might be releasing the keys too late, and cause the bootloader to ignore the instruction.

Note, when executing PWR + RST key combo, you need to release it exactly when you see the Khadas logo, any longer it will simply reset and reboot.

Initially mine never had a Khadas Logo (v1.2 Board) but had this military Style VIM Logo, and it definately first booted from external media after i flashed the Ubuntu Image to the Board.
Nevertheless i works now, only was harder than i expected.