Boot Into Upgrade Mode impossible


#22

Hi Balbes150,

Here is the u-boot for VIM2.

Thanks.


#23

Hi Numbqq.
Do I understand correctly that this u-boot for firmware versions of Ubuntu (not DualOS) ?


#24

Hi balbes150,

Yes, It’s only for Ubuntu, maybe @terry can provide the u-boot for DualOS.

Thanks.


#25

Which branch in git khadas\u-boot used to build the bootloader for DualOS ?
I see branches that you can use for Android (Nougat) or to Ubuntu.


#26

Yup, works great for me. (Another benefit of no reset button is this is a lot easier for those of us with big, fat fingers :grinning:)


#27

I pushed the MultiOS branch on our github. It is used to build the bootloader for DualOS


#28

Hi @RDFTKV,

I have installed reboot app and with that app I can reboot to recovery.
After that I see only option to update from adb and ext.
If I enter update from ext I see a lot of errors regarding scdard read only or similar.

My sdcard was formated in winblows 10 when I tried to update over sdcard (ended with update over USB cable) so not sure why recovery can’t mount my sdcard (it is 64GB sdcard)?

S.


#29

Hello, I will check tonight.
BTW What firmware is on your VIM2?


#30

Hi,
the latest official vim2 from khadas.

S.


#31

You probably used the default formatting. For large carriers are not using the default FAT.
To work rekoveri (update) should only be used FAT.


#32

Yes i think it was formated as exFat. Will try with plane FAT :slight_smile:

S.


#33

My Vim2 Pro is not booting into update mode , only had it for 45 days or so , was updating from Ubuntu MAte to Ubuntu Server and had tried the dual boot options before thaT , now I can’t get it to do things , no screen , no update mode and only a white light saying power is on , tried all of the above with no success . help


#34

How did you try to boot into upgrade mode?Can you describe it in detail? Maybe you need to boot into upgrade mode with MRegister Mode.


#35

I used MRegister and got Ubuntu Mate installed now , wanted Ubuntu server but USB upgrade failed everytime , re-downloaded the image file , even tried sd card install , guess Mate only , yeah power button must be dead , sad


#36

Hello, Glad you got firmware on it. I have not tried to flash the server version, so cannot comment on that.

Considering its size, VIM(2) power buttons seem to be fairy rugged. By no means, does that rule it out.
I assume your VIM2’s power switch will not turn the VIM2 on.
Is it rigidly fixed to the PCB? Do you have a multi-meter to check the switch for function?


#37

I also have become the victim of this problem.

I have played a bit with my VIM2 MAX, so i decided to now go and permantaly put Libreelect on it to be able to update constantly the easy way. However although

using Rufus, renaming the to the dtb.img having dual os (ubuntu + android) on it, i cant boot in neither Ubuntu nor LE.

Anyone a solution that i haven’t found yet on the forum?


#38

Yes, the reset button not required (Tested with VIM2 Basic)


#39

Install new u-boot into eMMC via a SD card: http://docs.khadas.com/develop/UBootUsage/


#40

I am in your club now. Purchased VIM2 max on Gearbest and got 3 month after placing the order… and it does not work. No signal on HDMI, no reaction on pressing buttons, only white light - power on. Have tried to boot into upgrade mode in different ways described here, including m-register, with no results. Wasted money. Very disappointing.


#41

Where are you living? If you are from Russia, you can send your model to me by mail, I will check and if it is really faulty, will help to solve the issue with the exchange.