Bad Firmware images?

I’ve just received my VIM2 Max. Very nice board, but I have several issues with what appears to be bad images. It seems that most of the latest Ubuntu and Dual OS images (dated 2019) will not load on the VIM2 (v1.4) or even successfully create a SD card to upgrade with. Older images seem to be fine however.

I’ve also checked MD5 checksums and they are correct. Yet, using the USB upgrade method, the upgrade fails with a validating of the file and the SD Card fails validation using the Burn Card maker tool.

Is the problem specific to the V1.4 of the VIM2 or are there other known issues using several of the recent images with the latest VIM2.

I have been able to reload the latest Android to the VIM2, but only the oldest Dual OS image will load without error… and again, older Linux images work, but not newer ones.

Hopefully I’m missing something (user error perhaps) but I can’t think of what it would be.

Regards, KM

Hi @floobydust, can you tell me which image that you used,we will check it with VIM2 Max.

Hi Frank,
I’m using the latest Dual OS image from here:

Also, the latest 2019 dated Ubuntu images fail as well:

I would like to have the latest Android Nougat (that came on the VIM2 preloaded) and the latest Ubuntu Mate desktop… but I don’t think these two OSes have been put into a single Dual OS image as of yet.

I think the VIM2 is a really slick board… I’m just struggling a bit up front, so hopefully it’s a temporary hurdle as I’m new to the VIM2.

Regards, KM

Hi @floobydust, I’ll confirm this later.

Hello @floobydust

Can you provide more error information for us?

By the way, have you tried to burn the image in ubuntu ?

Well, I’m not using linux as a desktop. I’m using Windows 7 Pro 64-bit in a VM using VMware Fusion on a MacBook Pro. The MacBook has a SD Card reader, which I can link to the Win7 VM. From there, I simply use the Burn Card Maker utility. On several images, it just fails at the end and suggests using a different card reader. Some older (2018 dated) images burn to the SD card okay, and install okay.

In other scenarios… again, using Win7 in the VM, I’m using the USB Burning Tool app to upgrade directly to the VIM2 via the USB C port. I’ve tried with additional power as well via the USB connector, but certain images continue to fail. It loads the rootfs image to 99%, then fails on verifying the partition.

I’m going to download multiple images and do more thorough testing on what works versus fails and will give you a more detailed list. It will probably take a bit of time as I need to download each 7z file, decompress and then attempt to burn it onto the SD card.

Regards, KM

1 Like

@floobydust tried a different SD card? I have a Mac too…

It’s a new Sandisk 8GB card. I wouldn’t expect it to work for some images and not others, as all are well less than 8GB in size. The actual error from the app is (L1126). I’ll grab a 16GB card and try some of the failing images again…

In any case, I just tried a new Ubuntu Desktop only image:


I burned this to the SD Card which was successful, then updated the EMMC on the VIM2 MAX and that worked.

I’ve downloaded (again) the linked Dual OS images, and have used the the USB Burn Tool directly:

VIM2_DualOS_Nougat_Ubuntu-16.04_V180622.7z - failed
VIM2_DualOS_Nougat_Ubuntu-16.04_V171028.7z - successful
VIM2_DualOS_Nougat_Ubuntu-16.04_V170818.7z - successful

The error reported shows as as verify partition failed on linux.

Regards, KM

1 Like

Well, I tried a 16GB SD Card (also Sandisk) and the same failures occur with the Dual OS images. Also, I tried to load the latest Linux image via the USB Burn Tool and it failed as well:


Oddly, this same image could be burned to the SD Card and installed on the VIM2, just not by a direct USB based install. Very strange indeed.

Regards, KM

1 Like

So, I downloaded the ISO image for Ubuntu 18.04 and created a virtual machine under Fusion, loaded up the build environment (Fenix) and have successfully created multiple VIM OS images (Linux only so far) and using the Ubuntu burn tool can load these into the VIM2 without issue.

Needless to say, the Windows tools are not very good and error prone. While I prefer a nice graphical tool (having started with 8-bit micros in the 1970’s), sometimes you just have to use a command line… oh well.

So, are there any plans to have a Linux build that can leverage the video capabilities of the Amlogic SOCs?

Regards, KM

For the USB burning tool on windows fail issue, we haven’t find out the reason…

We can benefit from mainline kernel in the future…

Regarding the Windows burn tools… I’m running on Win7 Pro 64-bit (latest updates/patches, etc.) under Fusion 11.1 on OSX Mojave. Perhaps it functions better on Win10, but as little as I use Win7, no reason to upgrade it. I’ll just keep the Ubuntu VM for working with the VIM2.

Thanks again for the prompt replies!

Regards, KM

1 Like