Audio on VIMx.Debian.9.stretch.server.kernel-5.5.X.mainline.emmc.kresq

Hello. I am testing the Debian 9 stretch server kernel 5.5.x from Khadas repo on VIM3.

It runs nice but no HDMI Alsa sound. How can i enable HDMI Audio?

aplay -l shows

Blockquote
**** List of PLAYBACK Hardware Devices ****
card 0: G12AKHADASVIM3 [G12A-KHADAS-VIM3], device 0: fe.dai-link-0 () []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: G12AKHADASVIM3 [G12A-KHADAS-VIM3], device 1: fe.dai-link-1 (
) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: G12AKHADASVIM3 [G12A-KHADAS-VIM3], device 2: fe.dai-link-2 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0

lsmod shows

Blockquote
Module Size Used by
fuse 110592 2
bnep 24576 2
uvcvideo 98304 0
videobuf2_vmalloc 20480 1 uvcvideo
uas 24576 0
hid_lenovo 20480 0
dw_hdmi_cec 16384 0
dw_hdmi_i2s_audio 16384 0
hci_uart 86016 0
btsdio 16384 0
btqca 16384 1 hci_uart
btbcm 16384 1 hci_uart
brcmfmac 278528 0
btintel 24576 1 hci_uart
brcmutil 20480 1 brcmfmac
bluetooth 352256 28 btqca,btsdio,btintel,hci_uart,btbcm,bnep
cfg80211 372736 1 brcmfmac
ir_nec_decoder 16384 0
meson_vdec 61440 0
v4l2_mem2mem 36864 1 meson_vdec
meson_dw_hdmi 20480 0
ecdh_generic 16384 2 bluetooth
videobuf2_dma_contig 20480 1 meson_vdec
ecc 32768 1 ecdh_generic
dw_hdmi 40960 2 meson_dw_hdmi,dw_hdmi_i2s_audio
meson_drm 57344 2 meson_dw_hdmi
videobuf2_memops 16384 2 videobuf2_vmalloc,videobuf2_dma_contig
videobuf2_v4l2 32768 3 meson_vdec,uvcvideo,v4l2_mem2mem
rfkill 32768 3 bluetooth,cfg80211
videobuf2_common 49152 4 meson_vdec,videobuf2_v4l2,uvcvideo,v4l2_mem2mem
drm_kms_helper 204800 5 meson_dw_hdmi,meson_drm,dw_hdmi
rc_khadas 16384 0
videodev 245760 5 meson_vdec,videobuf2_v4l2,uvcvideo,videobuf2_common,v4l2_mem2mem
drm 495616 6 meson_dw_hdmi,meson_drm,drm_kms_helper,dw_hdmi
meson_ir 16384 0
mc 53248 5 videodev,videobuf2_v4l2,uvcvideo,videobuf2_common,v4l2_mem2mem
ao_cec_g12a 16384 0
rc_core 45056 4 rc_khadas,ir_nec_decoder,meson_ir
cec 57344 3 dw_hdmi_cec,ao_cec_g12a,dw_hdmi
meson_rng 16384 0
rng_core 20480 2 meson_rng
meson_canvas 16384 2 meson_drm,meson_vdec
drm_panel_orientation_quirks 16384 1 drm
rtc_meson_vrtc 16384 1

Curretly I am using pulseaudio to route audio to another machine with good amplifier and speakers. This is a very nice feature of pulseaudio!

It needs a script which needs to be run on everyboot to connect the HDMI-Audio to pulseaudio.

This script is a work of balbes and I have been using it on Manjaro since the beginning, I am not sure if it will work for debian image.

Maybe @hyphop can help you with hdmi sound on debian image.

Can you see the sound card under alsamixer ?
If you do then can you share the screenshot?

in alsamixer i see G12A-KHADAS-VIM3

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: G12AKHADASVIM3 [G12A-KHADAS-VIM3], device 0: fe.dai-link-0 () []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: G12AKHADASVIM3 [G12A-KHADAS-VIM3], device 1: fe.dai-link-1 (
) []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: G12AKHADASVIM3 [G12A-KHADAS-VIM3], device 2: fe.dai-link-2 (*) []
Subdevices: 1/1
Subdevice #0: subdevice #0

@Spikerguy where is the script?

Script can be found here.

I enable this service on every boot using systemd service.

You might have to change the card name to G12AKHADASVIM3, I guess so.
Try and see if it helps.

4 Likes

With both hdmi monitors aplay and mplayer playback fine (they see the device) but i hear nothing. I have tried with and without pulseaudio. Pulseaudio sees no hardware device.

alsamixer looks like this.


i bumped up volumes on the sliders i could see.

this is the debian 5.5 kernel

[Also i hate to complain but typing in the editing window is too slow on these forums. It takes 30 seconds of waiting to see a sentence that I typed.]

@clort76 By chance are you using a mobile phone, or an old computer ?

Tping on pale moon, Khadas vim 3. There’s some heavy processing javascript interpreting every character typed. A short sentence takes 20 seconds to see - a long sentence takes over half a minute.

Really?, I have never had such a problem on mine, usually a split second for such sentences Maybe you have it set in powersave mode ?

https://meta.discourse.org/t/why-do-i-feel-writing-in-discourse-composer-became-slow/148948/4

Problem has been identified: “This is really really bad”. Khadas needs to upgrade discourse server software.

Damn, we really need to optimise our server :upside_down_face: