Ask Us Anything

Did you test gnome desktop using vim’s, will it work with ubuntu 20.04?

About vpu driver, it is mainlined with kernel 5.7, are you testing it?

I have been viewing rpi4 videos, they have one interesting thing, chromium media edition browser, it looks like all streaming services like netflix and youtube work well under it, i know vim can’t be compared with rpi4, but is it possible to adjust it for amlogic devices?

About panfrost/lima, are they usable on vim’s, i know it should work fine on vim2, but is it ok for end users of vim1 or 3?

When can we expect working images with some of the stuff mentioned here, especially now when ubuntu 20.04. is out?

@Gouwa, @numbqq, @Frank, @hyphop, @Terry ?

Yes, I have tested Ubuntu 20.04 linux 5.6 with gnome desktop, but seems not smooth as XFCE weeks ago. At that time, Lima/Panfrost doesn’t perform well on Ubuntu 20.04, but well on Debian Buster. Ubuntu 20.04 is released now, I haven’t checked yet.

Haven’t checked yet, when 5.7 released I will check.

Lima works on VIM1 and panfrost works on VIM2/Edge now. For VIM3/L panfrost will be supported in the future. We already provide the boards for to panfrost developers.

I have already added ubuntu 20.04 support in Fenix. But for the release image need more time.

About lima driver for Vim1, does it work with more demanding desktops like gnome or kde plasma?

Is it possible to install it on the current images, if so can you post a tutorial about it?

@numbqq, @Gouwa, @Terry ?

As I tested, Debian 10 has better performence then Ubnuntu 20.04.

I tested XFCE and GNOME, XFCE is better than GNOME.

You can’t. In order to using lima, you need to update mesa. So you have to use Debian 10 or Ubuntu 20.04. All source is avaliable on GitHub, you can build yourself if you want to try.

I know it isn’t the right place to ask, but i was watching a youtube video about lima driver, where i needed to add oibaf ppa to be able to install lima driver. I installed it, and after that i needed to edit armbian-defaults.conf file, i set acceleration from none to glamor, it looks like it worked because i got mali 450 recognised in glmark 2 with score of 196.

After that, something strange happened, i don’t have any sound now, and chromium browser starts with blank page, it looks like a white window, with no options or anything.

I have reverted acceleration to none, chromium now starts, but sound is still not coming.

I am using armbian 20.05.03., ubuntu 20.04, kernel 5.7 rc2.

Was this video even the right way to install and run lima, or did i need to edit some other line except the one that adds acceleration?

I know you were talking about compiling, but my knowledge is not that great, i managed to compile one app few months ago, but they had very clear instructions, here i don’t have a clue how to start?

@numbqq, @Gouwa, @Terry?

Hello, any estimates or guesstimates for android 64bit support (vim3)?


The Android 9 and android 10 don’t support 64bit. And we will add 64bit support on Android 11 at Q4.


Q4, seems so far away, but sounds reasonable. Ok, thanks for an answer. :smile:

  • What is the current status of mainline Linux on VIM3L ? (GPU, VPU, Wifi/BT …)
  • Can I use a camera on VIM3L without ISP ?

For the FAQ it will be a good idea to try explain the relationship between kernel, uboot, microcodes(mali etc …)

Hi, is it possible (without being a developing expert) to reprogram the VIM3L IR receiver to work with other IR remotes (in Android)?

why complicate when there is a gyroscope :slightly_smiling_face:
but in general if the remote control is programmable, then you can!

Will you be releasing Ubuntu focal soon?

Yes, we plan to release in the end of this month.

1 Like

Which kernel will you use?

Can you update fenix repo, kernel and stuff, 5.7 is still rc, but i would like to use it.


You can try 5.7 rc on Manjaro from unstable branch.
linux-vim is the package name.

1 Like

Is there some info about New M2X board. Video about case possibility.

Hello, Much info on the New M2X can be found here.

Haven’t seen a video yet on the Khadas Channel.


What about PoE with new M2X? I see no power supply there :frowning:

1 Like

Does not look like the Ethernet components are there. So likely those were dropped in the interest of a slimmer M2X.
Original M2X still available in the Khadas shop for those needing POE.
Looking at each version’s price would suggest the new M2X would not have all the features of the original.