Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC


#263

You can freely use previous versions of Armbian (or any other Linux) with kernel 3.14 and build c2play on VIM1 S905X for it. All the necessary libMali libraries are there. libhybris is not needed for c2play on S905X. It is only used on S912 (because there are no native libMali libraries for Linux).


#264

I installed Armbian 5.62 with uboot 2018 and I have intermittently in the network, I tried to manually set the speed on 10 Mhz but still decoupling me. I mention that it is in dhcp mode. Does anyone have any method of eliminating repeated decoupling?
Thank you.


#265

New version 20181018 of the image with kernel 4.19 and fixed MPV config.


#266

New ver 5.64 20181019

After fixing the MPV config, it became possible to watch full screen video up to 1080p on VIM1. The quality of course is not perfect, but enough for use in desktop mode. For high-quality video playback 1080p and 4K need to use specialized systems Libreelec. To watch Youtube videos in full screen, you can use the SMplayer + Smtube bundle with the corresponding options setting.


#267

For those who want to work on HW support on their own, there are two components on the site.

  1. Module “mali.ko”
  2. Archive with libMali.

The working version of xf86-video-armsoc is missing. I have a package (for Xenial) that gathered Numbqq (dev with Khadas), but the system does not accelerate and it needs to be corrected.


#268

For those who have issues with wired networking on VIM2 in the latest 5.64 images, I have downloaded a test dtb file (with the patch added). Please to those who have a problem with the network, check this option and write out the result.


#269

Just curious: what change did you apply to kvim2 dts file to improve wired networking ?


#270

^ probably this one, which is an educated hunch based on similar reports of ethernet issues under load with the Odroid C2 and other Amlogic devices.


#271

Yes, this is an old patch, I used it for a long time, even for the s905 Vega s95.


#272

Cool. I use similar eee-broken-1000t for my minimx-g meson-gxbb-p200 dts.
Will try it on meson-gxm-khadas-vim2 soon and let you know.
FYI: my MINIMX-G runs my 4.18.x-gentoo kernels just fine but my VIM2 had network issues.
In fact, for meson-gxbb-p200 I have amlogic,tx-delay-ns = <4> too, but not sure if such would eventually also be needed for meson-gxm-khadas-vim2.


#273

sorry to continue slightly off topic
I tried 4.18.5-gentoo eee-broken-1000t in meson-gxm-khadas-vim2 but when I do heavy building over network NBD drive eventually system hangs. amlogic,tx-delay-ns = <4> does not help (in fact it makes network very slow).
Last kernel with good results is 4.16.1-gentoo with plain meson-gxm-q200.
I recall meson-gxm-q200 was not good for 4.18.5-gentoo but I will try it again soon.
Keep U informed


#274

good news (at least for me)
meson-gxm-q200 with eee-broken-1000t has perfect ethernet performance for mainline 4.18.5-gentoo vanilla kernel. Thanks!


#275

@balbes150
Do I need Android 8.x on MMC in order to run the latest Armbian_5.64_Aml-s9xxx_Ubuntu_xenial_default_4.19.0 on my KVIM2?
Thanks!

PS: will Android 8.x break CoreELEC sturtup?


#276

There is no such requirement. To start Armbian kernel 4.19 standard firmware that comes default from the factory.

I don’t know what is necessary for coreelec.


#277

Update version 5.64 201114.
Added support for BT on VIM1 (s905X).


#278

Update version 5.64 201116.
add ZRAM


#279

Version 5.67 20181117.

Added support for ISCSI and deb packages kernel, header etc.

The version of the image with Xenial - will be assembled only on request.

p.s. When checking, it turned out that WiFi works on Khadas VIM2 Basic (with AP6356S chip). Khadas VIM1 (s905x) works WiFi and BT. :slight_smile:


#280

Accidentally discovered in the latest version of Armbian 5.67 (VIM2) reaction (sound is added and decreased when the test video is played) control the sound volume in MPV from the remote control from Khadas. I wonder if it’s just me or other people’s as well ?


#281

Tried to run Armbian_5.67_Aml-s9xxx_Ubuntu_bionic_default_4.19.0-rc7_desktop_20181117.img.xz on my KVIM2 Pro (3/32) uboot 2015 from microSD.

No USB at all: lsusb shows two linux root hubs and nothing more. Both my USB keyboards wasn’t detected as well as my USB flash drive.
I had to use USB-UART in order to somehow get an access to my KVIM2.
Another thin is that dhclient doesn’t work for me. The eth0 is up, but wouldn’t get an IP.

Before writing the image to microSD I’ve tried to start my KVIM2 from USB Flash drive, but it failed with error: “alert! label=ROOTFS doesn’t exist”. Most likely it’s because of nonworking USB.

Am I doing something wrong? @balbes150, could you please point me to the right way?
Thank you!


#282

Hi
This is a classic mistake. :slight_smile:
You did not set the correct dtb. Now this is done differently.

Just swapped comments with line descriptions from dtb on the vim1 vim2.


Ambrian en kodi