Aosp keyboard not appearing

I recently received VIM3.
What a powerful little board.
One problem though keeps bugging me.
I cannot for the life of me get the software keyboard to appear.
When I click the search bar in Google play I get a blinking cursor and nothing else.
Tried with a hardware keyboard as well.
My Logitech k800 works beautifully in both windows an Linux Mint but not a single peep from the VIM3.
No problems with the mouse at all.
Any thoughts?

Hello, I have firmware VIM3_Pie_V190809 installed. I have no issues using hardware keyboard, wired or wireless(Logitech K-400 plus) to enter text in fields.
For the Onscreen keyboard, go to Settings/More Settings/Device Preferences/Keyboard&Autofill/Current Keyboard and enable Android Keyboard(AOSP).
See if that helps.
If this does not help, you can install Gboard - the Google Keyboard from the app store.

Hi RDFTKV and thank you for the reply.
I got the hardware keyboard working. Danish keyboard layout took a little doing. The software keyboard however still eludes me. Android Keyboard(AOSP) is enabled. Google keyboard is installed and tried enabled. I tried with the hardware keyboard attached and without the hardware keyboard attached. Nothing seems to work. I hadn’t planned on using a hardware keyboard at all. The VIM3 is replacing an old Ricomagic mediaplayer in my living room. Any thoughts appreciated.
Regards elo.

Which firmware version is installed on your VIM3?

He! Took a while to find. In the top of the menu as opposed to my phone and tablet which post the information towards the bottom.
Human! Thou are indeed a creature of habit. :joy:

1 Like

LOL. Yes OS makers like to keep us on our toes.:grin:

I have the same firmware you listed, it is the latest.

You installed this app and still no onscreen keyboard?
I installed that app, it asks for a few settings changes. Once those were done the onscreen keyboard worked.
Even after uninstalling that app, the onscreen keyboard still works. So I think it is more of a settings thing. I have looked but cannot find where they hide the setting the Gboard app had me change. Maybe the languages difference is a factor, though I would not think so.

Since you are using your VIM3 as a media player, you may be interested in some custom ROMs(firmware) offered by superceleron. He offers a regular Android Pie as well as an AndroidTV.

If you have not got much time invested in your VIM3 setup and have not added many apps or files, maybe try a factory data reset and try the Gboard app again.
Factory data reset is at Settings/More Settings/Device Preferences/ Reset.

I wish I could be more helpful, but without experiencing the issue here, it is hard to troubleshoot.

If all else fails, one of the Khadas staff may need to intervene.