AOSP into VIM3: Burn Tool usage

Hello all,

Hope you are OK

Im newbie in KHADAS Vim3 and I want to flash AOSP by USB_Burn_Tool

As I have read in some post within this category I have downloaded the IMG VIM3_T_AOSP_V211126.tar but there are multiple img…
boot.img, cache.img , etc…

My question is simple. How should I pack all those IMGs so that this tool can recognize it and perform the flash?

Any suggestion to tackle this issue it would be appreciated…


as far as i know, android firmware, the only ones that can be flashed with the usb burn tool is the official ones and ones from superceleron. everything else has to be flashed the manual way.

I think that some people have managed to get the instructions to work on windows, but it is largely hit or miss, and linux seems to work best for this.


If you want to use USB_Burn_Tool to burn firmware, just update.img, please refer to products:sbc:vim3:install-os:install-os-into-emmc [Khadas Docs] -via-usb-tool.

If you want to burn other img, you can use the fastboot command to operate, the adb command reference is as follows:
adb root
adb disable-verity
adb reboot bootloader
fastboot reboot fastboot
fastboot flash boot_a boot.img
fastboot flash dtbo dtbo.img
fastboot reboot

Hello @xiong.zhang

I have found 2 issues:
1- With AOSP img VIM3_T_AOSP_V211126 the Touch Screen does not work, only via HDMI. The Khadas OS VIM3_Pie_V211220 Vim3 does work with Touch Screen.
2- Once AOSP VIM3_T_AOSP_V211126 is installed, I have the problem that SIMCARD can not be recognized , but for KHADAS OS VIM3 VIM3_Pie_V211220 it’s working properly.

Do you know if there are limitations for AOSP regarding the add ons proposed by KHADAS?


With AOSP img VIM3_T_AOSP_V211126 is preview ROM

Be note that the Android 12 are still not quite stable til now, and we are working on to improve it and will continue to built and release new images in the future.

Sorry, we will fix some issues and update the new firmware in the future

Thanks for your quick response @xiong.zhang!

In any case, I’ll try VIM3_R_AOSP_V210604 I think this img is Android 11 right?

This img is Android 12, there are some instructions for this connection, you can refer to the following

Thanks a lot @xiong.zhang !

Hello @xiong.zhang , @goenjoy

I have tried with Android 11 and I still get the same results

1- With AOSP img the Touch Screen does not work, only via HDMI.
2- Once AOSP is installed, I have the problem that SIMCARD can not be recognized , but for KHADAS OS VIM3 it’s working properly
What worries me most is that AOSP does not work with M2X extension, could you confirm that this is so? or am I doing some wrong configuration.

I have tried the images that are in the download folders and additionally I have created an image (yukawa) in my Ubuntu environment, in the same case the 3 images the M2X Extension Nano SIMCARD is not recognized

Thanks in advance for your support

AOSP only support HDMI display and not support M2X extension.
Generally, one post only describes one question. In addition, Android and ubuntu cannot be asked in one post.

Apologies for the 2 questions in same topic… it will not happen again
Thanks for your confirmation