Android won't Boot vim2


#1

Hi Gouwa,

I’ve been stuck on a problem for about two weeks. When I start up my vim 2, it shows the “khadas” logo but android never boots. I’ve tried a number of different ROMs, different USB-C cords (2+ amps), and both using the burn-tool and a burnable SD card. I’ve also plugged out to erase the eMMC to start fresh with no success. This has become very discouraging so any help is much appreciated!

Thanks,

Nathan


#2

Hi nblandfo:
Which version ROMs you installed for your VIM2?

Have fun!


#3

#4

Have you had any firmware running on it before?

Anyway… I had this as well. In my case it had to do with power requirements… is the power adapter supplying enough Ampere… 2A should be good.
Also during flashing the Vim2 eMMc with new firmware there are some power issues with my PC. My usb ports on my laptop are not powerful enough. I need to add a charger with male usb plug to the usb port on the Vim next to the usb-c port before the burn can become successful.
When I don’t do that, I only get the khadas logo on my Vim2.


#5

2000mah is good for the normal Kadas Vim, for the Khadas Vim2 you need more power.
As exemple i show a good adapter.
Its the adapter for the Raspberry 3100mah 5 volt.
It haves a OTG plug, so you need a plug from OTG to USB-C. (In China 10 for 4 Dollar)
The link is to a Dutch store to show you what I mean. (15 euro/16 Dollar)
https://www.allekabels.nl/raspberry-pi/7389/1415984/voeding.html
And the plug for OTG to USB-C : https://www.allekabels.nl/htc/5780/1371998/usb-micro-naar-usb-c-adapter-20.html

For the starter of this topic,
If you need good firmware, I can help you no problem.
(One thing, I have only Android, not Duall Os versions)
Send me a email : salora1972@gmail.com , and i send you some files out my Dropbox.
In the beginning i haves also problems.
When i send a email, i put inside a user manuel how to use this firmware, and i give the good working software.
Sorry for my English, I speak it good, but on paper hahaha #Helppp
Normaly i Always in the Dutch forums, thats easyer for me.
When you send me a email, you have it in the end of the week.


#6

I tried VIM2_Nougat_V180619 last night. I’ve also tried superceleron’s SCV1 img that was recommend on another Khadas forum.


#7

Still stuck on the khadas logo.

I used the following 2.4 A usb-c cord plugged into the vim2 and my laptop usb port:

Per your instructions I added the following male to male usb plug to the usb port on the vim next to the usb-c port:

I tried this both into an additional usb port on my laptop as well as into an iPhone block charger and had no luck:
https://www.apple.com/power-adapters/

Perhaps the block charger doesn’t output enough power?

Thanks for all the replies!


#8

Laptops often don’t give a lot of juice through their USB connections, so if your are flashing the VIM with the laptop you will need extra power… but it sounds you already did that.
Once you flashed and removed the VIM from the laptop, you will need to use the 2A adapter to power the VIM through the USB-C port.

If you did all that, and still have a problem, with stable firmware from the khadas website, then your problem is obviously not related to power.

There are several things unclear to me.

  • My VIM2 came with firmware pre-installed. Did yours too? Did it work out of the box? Why did you start flashing firmware first? I am just curious. If it didn’t work then, you could have send it back.
  • Have you tried several different power adapters to boot the VIM up? What do you mean that you plugged out to erase eMMC?
  • Are you booting the VIM2 with a microSD in? When you upgrade through using the USB-C cable method, you do not need a MicroSD.
    https://docs.khadas.com/vim2/UpgradeViaUSBCable.html
    Then when you boot up the VIM2, it should start from eMMc. So don’t have a MicroSD in.

#9

I’ve tried flashing the VIM2 with additional power (USB-A male to male next to USB-C port), and although the burning tool says it is successful, I still cannot boot past the Khadas logo.

To answer your questions:

  1. The VIM2 did come with pre-installed firmware, which booted up fine.Then once I tried upgrading the firmware, all of a sudden it would never make it past the khadas logo.

  2. I have tried several different power adapters. By plugging out I’m referring to break mode in:
    https://docs.khadas.com/vim2/HowtoEraseEMMC.html
    I did that only after failing to get past the khadas logo after several flash attempts, but it did not help anything.

  3. I’m not booting with the microSD in. I used a burn card to flash the update image after the usb-c method wasn’t working. After flashing using the burn card, I removed the card before rebooting, but could not get past the khadas logo via this method either.

Thanks for all the replies. Still trying to figure this one out.


#10

@Gouwa, @BdK71
Any other suggestions? Doesn’t seem like power is the issue.