Android 11 on VIM3L

Hey team,

is that possible to build Android 11 for VIM3L?
I’ve tried the instructions from this post Flashing Android 11 on VIM3 - #8 by

But, unfortunately, that doesn’t work for the VIM3L.
Thanks please help…

@cwang95 VIM3L

source build/
lunch yukawa-userdebug
  • flash Uboot:
cd path/to/aosp/device/amlogic/yukawa/bootloader/
./tools/update write u-boot_kvim3l_noab.bin 0xfffa0000 0x10000
./tools/update run 0xfffa0000
./tools/update bl2_boot u-boot_kvim3l_noab.bin
fastboot oem format
fastboot flash bootloader u-boot_kvim3l_noab.bin
fastboot erase bootenv
fastboot reboot bootloader
  • press reset key.
  • flash img:
cd out/target/product/yukawa
fastboot flash boot boot.img
fastboot flash super super.img
fastboot flash cache cache.img
fastboot flash userdata userdata.img
fastboot flash recovery recovery.img
fastboot flash dtbo dtbo-unsigned.img
fastboot reboot


Thanks for the feedback,
The problem I had was that I can’t build the super.img out.
I tried your post here but I can’t boot into the system successfully.

When I checked the system log, it showed lots of exceptions when booting.
Is there another way to flash Android 11?
Or, I guess this question is more specific, how can I enable dynamic partition for it?

You can use Android 12 to test VIM3L.